# CVE-2011-1497: Cross site scripting in actionpack Rubygem

> An XSS flaw in the auto_link function allows attackers to inject malicious scripts, requiring an upgrade to Rails.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Oct 2021
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-q58j-fmvf-9rq6

## What is CVE-2011-1497?

CVE-2011-1497 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 19 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site scripting vulnerability flaw was found in the auto_link function in Rails before version 3.0.6.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2011-1497?

2 open source packages ship an affected version, including actionpack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | From 3.0.0.rc | 3.0.6 |
| `actionpack` | RubyGems | From 3.0.0.rc | 3.0.6 |

Products: Rubyonrails Rails.

## How do I fix CVE-2011-1497?

Upgrade actionpack to 3.0.6 or later.

## Is CVE-2011-1497 being exploited?

There is no known exploitation of CVE-2011-1497 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-1497 and fix it if it is affected.

What it is: CVE-2011-1497 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 19 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2011-1497 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionpack (RubyGems): affected from 3.0.0.rc; fixed in 3.0.6
- actionpack (RubyGems): affected from 3.0.0.rc; fixed in 3.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-1497/ (Markdown: https://insights.sbomify.com/CVE-2011-1497/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-1497
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-1497
- OSV: https://osv.dev/vulnerability/CVE-2011-1497

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-1497/
Summaries are generated and may contain mistakes; the official description above is the record.
