CVE-2011-1940 phpMyAdmin Vulnerable to Cross-Site Scripting
Remote attackers can inject arbitrary web script via crafted table names in phpMyAdmin, requiring user interaction to execute malicious code.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2011-1940?
CVE-2011-1940 is a medium-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 26 Jan 2012. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.3.x before 3.3.10.1 and 3.4.x before 3.4.1 allow remote attackers to inject arbitrary web script or HTML via a crafted table name that triggers improper HTML rendering on a Tracking page, related to (1) libraries/tbl_links.inc.php and (2) tbl_tracking.php.
Weakness: CWE-79
Which versions are affected by CVE-2011-1940?
4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 3.3.0 | 3.3.10.1 |
phpmyadmin/phpmyadmin Packagist | From 3.3.0 | 3.3.10.1 |
phpmyadmin/phpmyadmin Packagist | From 3.4.0 | 3.4.1 |
phpmyadmin/phpmyadmin Packagist | From 3.4.0 | 3.4.1 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2011-1940?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 3.3.10.1 or 3.4.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2011-1940 being exploited?
There is no known exploitation of CVE-2011-1940 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as DEBIAN-CVE-2011-1940, GHSA-4q58-5x28-53wv.