CVE-2011-1949 Plone Cross-site Scripting vulnerability
Authenticated users can inject arbitrary scripts via the safe_html filter in Plone, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2011-1949?
CVE-2011-1949 is a low-severity cross-site scripting vulnerability in Plone Plone, published on 6 Jun 2011. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in the safe_html filter in Products.PortalTransforms in Plone 2.1 through 4.1 allows remote authenticated users to inject arbitrary web script or HTML via unspecified vectors, a different vulnerability than CVE-2010-2422.
Weakness: CWE-79
Which versions are affected by CVE-2011-1949?
7 open source packages ship an affected version, including plone and Plone. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | All versions | 4.1.1 |
plone PyPI | From 3.3.2 | 3.3.6 |
plone PyPI | From 4.0a0 | 4.0.6 |
plone PyPI | From 4.1a0 | 4.1.1 |
Plone PyPI | From 3.3.2 | 3.3.6 |
Plone PyPI | From 4.0a0 | 4.0.6 |
1 more packages
Plone PyPI | From 4.1a0 | 4.1.1 |
Products include Plone Plone.
How do I fix CVE-2011-1949?
Upgrade plone to a fixed version for your release line: 4.1.1, 3.3.6 or 4.0.6.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2011-1949 being exploited?
There is no known exploitation of CVE-2011-1949 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-h6hq-c896-w882, PYSEC-2011-15.