# CVE-2011-2087: Apache Struts Multiple XSS Vulnerabilities

> Remote attackers can inject arbitrary web script or HTML via parameter values in Apache Struts 2.x Java Templates plugin, requiring user interaction to execute.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 May 2011
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-5pgj-r7c6-7c7w

## What is CVE-2011-2087?

CVE-2011-2087 is a medium-severity cross-site scripting vulnerability in Apache Struts, published on 13 May 2011. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in component handlers in the javatemplates (aka Java Templates) plugin in Apache Struts 2.x before 2.2.3 allow remote attackers to inject arbitrary web script or HTML via an arbitrary parameter value to a .action URI, related to improper handling of value attributes in (1) FileHandler.java, (2) HiddenHandler.java, (3) PasswordHandler.java, (4) RadioHandler.java, (5) ResetHandler.java, (6) SelectHandler.java, (7) SubmitHandler.java, and (8) TextFieldHandler.java.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2011-2087?

2 open source packages ship an affected version, including org.apache.struts:struts2-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-parent` | Maven | All versions | 2.2.3 |
| `org.apache.struts:struts2-parent` | Maven | All versions | 2.2.3 |

Products: Apache Struts.

## How do I fix CVE-2011-2087?

Upgrade org.apache.struts:struts2-parent to 2.2.3 or later.

## Is CVE-2011-2087 being exploited?

There is no known exploitation of CVE-2011-2087 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-2087 and fix it if it is affected.

What it is: CVE-2011-2087 is a medium-severity cross-site scripting vulnerability in Apache Struts, published on 13 May 2011. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2011-2087 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.struts:struts2-parent (Maven): affected all versions; fixed in 2.2.3
- org.apache.struts:struts2-parent (Maven): affected all versions; fixed in 2.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-2087/ (Markdown: https://insights.sbomify.com/CVE-2011-2087/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-2087
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-2087
- OSV: https://osv.dev/vulnerability/CVE-2011-2087

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-2087/
Summaries are generated and may contain mistakes; the official description above is the record.
