# CVE-2011-2088: XWork in Apache Struts Reveals Sensitive Information

> Remote attackers can obtain sensitive internal Java class path information via crafted s:submit elements in Apache Struts or WebWork applications.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2011
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-9ccm-g362-2r35

## What is CVE-2011-2088?

CVE-2011-2088 is a medium-severity vulnerability in Apache Struts, published on 13 May 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWork 2.2.1 in Apache Struts 2.2.1, and OpenSymphony XWork in OpenSymphony WebWork, allows remote attackers to obtain potentially sensitive information about internal Java class paths via vectors involving an s:submit element and a nonexistent method, a different vulnerability than CVE-2011-1772.3.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2011-2088?

2 open source packages ship an affected version, including org.apache.struts.xwork:xwork-core. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts.xwork:xwork-core` | Maven | All versions | 2.2.2 |
| `org.apache.struts.xwork:xwork-core` | Maven | All versions | 2.2.2 |

Products: Apache Struts, Opensymphony Webwork, Opensymphony Xwork.

## How do I fix CVE-2011-2088?

Upgrade org.apache.struts.xwork:xwork-core to 2.2.2 or later.

## Is CVE-2011-2088 being exploited?

There is no known exploitation of CVE-2011-2088 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-2088 and fix it if it is affected.

What it is: CVE-2011-2088 is a medium-severity vulnerability in Apache Struts, published on 13 May 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-2088 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.struts.xwork:xwork-core (Maven): affected all versions; fixed in 2.2.2
- org.apache.struts.xwork:xwork-core (Maven): affected all versions; fixed in 2.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-2088/ (Markdown: https://insights.sbomify.com/CVE-2011-2088/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-2088
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-2088
- OSV: https://osv.dev/vulnerability/CVE-2011-2088

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-2088/
Summaries are generated and may contain mistakes; the official description above is the record.
