{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2011-2107 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2011-2107 is a medium-severity cross-site scripting vulnerability in Adobe Acrobat, published on 7 Jun 2011. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2011-2107 and fix it if it is affected.\n\nWhat it is: CVE-2011-2107 is a medium-severity cross-site scripting vulnerability in Adobe Acrobat, published on 7 Jun 2011. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2011-2107 in the wild and no public exploit code.\n\nAffected product: Adobe Acrobat. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-2107/ (Markdown: https://insights.sbomify.com/CVE-2011-2107/index.md)","id":"CVE-2011-2107","markdown":"https://insights.sbomify.com/CVE-2011-2107/index.md","name":"CVE-2011-2107","record":{"aliases":["GHSA-rr7r-vwxf-ff4c","RHSA-2011:0850"],"analysis":{"component_type":"browser","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Adobe Flash Player","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML into Adobe Flash Player, potentially leading to code execution or security bypass.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"acrobat","vendor":"adobe"},{"product":"acrobat_reader","vendor":"adobe"},{"product":"flash_player","vendor":"adobe"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in Adobe Flash Player before 10.3.181.22 on Windows, Mac OS X, Linux, and Solaris, and 10.3.185.22 and earlier on Android, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors, related to a \"universal cross-site scripting vulnerability.\"","ecosystems":["Red Hat:rhel_extras:5::client","Red Hat:rhel_extras:5::server","Red Hat:rhel_extras:6"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in n/a","id":"CVE-2011-2107","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"adobe:acrobat","products":["adobe:acrobat","adobe:acrobat_reader","adobe:flash_player"],"type":"xss","year":"2011"},"n_packages":3,"n_references":16,"next":{"headline":"Other in n/a","id":"CVE-2011-2108"},"packages":[{"ecosystem":"Red Hat:rhel_extras:5::client","fixed":["0:10.3.181.22-1.el5"],"introduced":["0"],"last_affected":[],"package":"flash-plugin","purl":"pkg:rpm/redhat/flash-plugin","source":"RHSA-2011:0850"},{"ecosystem":"Red Hat:rhel_extras:5::server","fixed":["0:10.3.181.22-1.el5"],"introduced":["0"],"last_affected":[],"package":"flash-plugin","purl":"pkg:rpm/redhat/flash-plugin","source":"RHSA-2011:0850"},{"ecosystem":"Red Hat:rhel_extras:6","fixed":["0:10.3.181.22-1.el6"],"introduced":["0"],"last_affected":[],"package":"flash-plugin","purl":"pkg:rpm/redhat/flash-plugin","source":"RHSA-2011:0850"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2011-2106"},"products":["n/a"],"published":"2011-06-07","related":[{"cvss_score":9.6,"headline":"Adobe Acrobat and Reader Use-After-Free","id":"CVE-2021-28550","kev_date_added":"2021-11-03","published":"2021-09-02"},{"cvss_score":8.8,"headline":"Adobe Acrobat and Reader Heap-based Buffer Overflow","id":"CVE-2021-21017","kev_date_added":"2021-11-03","published":"2021-02-11"},{"cvss_score":8.8,"headline":"Adobe Reader and Acrobat Sandbox Bypass","id":"CVE-2014-0546","kev_date_added":"2022-05-25","published":"2014-08-12"},{"cvss_score":8.8,"headline":"Adobe Reader and Acrobat Use-After-Free","id":"CVE-2014-0496","kev_date_added":"2022-03-03","published":"2014-01-15"},{"cvss_score":8.8,"headline":"Adobe Reader and Acrobat Memory Corruption","id":"CVE-2013-3346","kev_date_added":"2022-03-03","published":"2013-08-30"},{"cvss_score":8.8,"headline":"Adobe Reader and Acrobat Arbitrary Integer Overflow","id":"CVE-2013-2729","kev_date_added":"2022-03-28","published":"2013-05-16"},{"cvss_score":8.8,"headline":"Adobe Reader and Acrobat Universal 3D Memory Corruption","id":"CVE-2011-2462","kev_date_added":"2022-06-08","published":"2011-12-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML into Adobe Flash Player, potentially leading to code execution or security bypass.","url":"https://insights.sbomify.com/CVE-2011-2107/"}