CVE-2011-2197 rails Cross-site Scripting vulnerability

Medium 4.3 Published Updated

Remote attackers can bypass XSS protections in Ruby on Rails to execute scripts via crafted strings, requiring user interaction.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2011-2197?

CVE-2011-2197 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 30 Jun 2011. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

The cross-site scripting (XSS) prevention feature in Ruby on Rails 2.x before 2.3.12, 3.0.x before 3.0.8, and 3.1.x before 3.1.0.rc2 does not properly handle mutation of safe buffers, which makes it easier for remote attackers to conduct XSS attacks via crafted strings to an application that uses a problematic string method, as demonstrated by the sub method.

Weakness: CWE-79

Which versions are affected by CVE-2011-2197?

8 open source packages ship an affected version, including actionpack and activesupport. It affects 2 products.

PackageAffectedFixed in
actionpack RubyGemsFrom 2.0.02.3.12
actionpack RubyGemsFrom 2.0.02.3.12
actionpack RubyGemsFrom 3.0.03.0.8
actionpack RubyGemsFrom 3.0.03.0.8
activesupport RubyGemsFrom 2.0.02.3.12
activesupport RubyGemsFrom 2.0.02.3.12
2 more packages
activesupport RubyGemsFrom 3.0.03.0.8
activesupport RubyGemsFrom 3.0.03.0.8

Products include Rubyonrails Rails, Rubyonrails Ruby on Rails.

How do I fix CVE-2011-2197?

Upgrade actionpack to a fixed version for your release line: 2.3.12 or 3.0.8.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2011-2197 being exploited?

There is no known exploitation of CVE-2011-2197 in the wild and no public exploit code.

All Rubyonrails Rails vulnerabilities

Sources

Also known as GHSA-v9v4-7jp6-8c73.

Is CVE-2011-2197 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free