# CVE-2011-2197: rails Cross-site Scripting vulnerability

> Remote attackers can bypass XSS protections in Ruby on Rails to execute scripts via crafted strings, requiring user interaction.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jun 2011
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-v9v4-7jp6-8c73

## What is CVE-2011-2197?

CVE-2011-2197 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 30 Jun 2011. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The cross-site scripting (XSS) prevention feature in Ruby on Rails 2.x before 2.3.12, 3.0.x before 3.0.8, and 3.1.x before 3.1.0.rc2 does not properly handle mutation of safe buffers, which makes it easier for remote attackers to conduct XSS attacks via crafted strings to an application that uses a problematic string method, as demonstrated by the sub method.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2011-2197?

8 open source packages ship an affected version, including actionpack and activesupport. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | From 2.0.0 | 2.3.12 |
| `actionpack` | RubyGems | From 2.0.0 | 2.3.12 |
| `actionpack` | RubyGems | From 3.0.0 | 3.0.8 |
| `actionpack` | RubyGems | From 3.0.0 | 3.0.8 |
| `activesupport` | RubyGems | From 2.0.0 | 2.3.12 |
| `activesupport` | RubyGems | From 2.0.0 | 2.3.12 |
| `activesupport` | RubyGems | From 3.0.0 | 3.0.8 |
| `activesupport` | RubyGems | From 3.0.0 | 3.0.8 |

Products: Rubyonrails Rails, Rubyonrails Ruby on Rails.

## How do I fix CVE-2011-2197?

Upgrade actionpack to a fixed version for your release line: 2.3.12 or 3.0.8.

## Is CVE-2011-2197 being exploited?

There is no known exploitation of CVE-2011-2197 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-2197 and fix it if it is affected.

What it is: CVE-2011-2197 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 30 Jun 2011. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2011-2197 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionpack (RubyGems): affected from 2.0.0; fixed in 2.3.12
- actionpack (RubyGems): affected from 2.0.0; fixed in 2.3.12
- actionpack (RubyGems): affected from 3.0.0; fixed in 3.0.8
- actionpack (RubyGems): affected from 3.0.0; fixed in 3.0.8
- activesupport (RubyGems): affected from 2.0.0; fixed in 2.3.12
- activesupport (RubyGems): affected from 2.0.0; fixed in 2.3.12
- activesupport (RubyGems): affected from 3.0.0; fixed in 3.0.8
- activesupport (RubyGems): affected from 3.0.0; fixed in 3.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-2197/ (Markdown: https://insights.sbomify.com/CVE-2011-2197/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-2197
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-2197
- OSV: https://osv.dev/vulnerability/CVE-2011-2197

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-2197/
Summaries are generated and may contain mistakes; the official description above is the record.
