CVE-2011-2204 Insertion of Sensitive Information into Log File in Apache Tomcat
Local attackers can read log files to obtain sensitive passwords when MemoryUserDatabase is enabled and JMX errors occur.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2011-2204?
CVE-2011-2204 is a low-severity vulnerability in Apache Tomcat, published on 29 Jun 2011. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Apache Tomcat 5.5.x before 5.5.34, 6.x before 6.0.33, and 7.x before 7.0.17, when the MemoryUserDatabase is used, creates log entries containing passwords upon encountering errors in JMX user creation, which allows local users to obtain sensitive information by reading a log file.
Weakness: CWE-200
Which versions are affected by CVE-2011-2204?
6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.34 |
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.34 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.33 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.33 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.19 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.19 |
Products include Apache Tomcat.
How do I fix CVE-2011-2204?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 5.5.34, 6.0.33 or 7.0.19.
Is CVE-2011-2204 being exploited?
There is no known exploitation of CVE-2011-2204 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-c57p-3v2g-w9rg.