{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2011-2486 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2011-2486 is a medium-severity vulnerability in n/a, published on 19 Nov 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2011-2486 and fix it if it is affected.\n\nWhat it is: CVE-2011-2486 is a medium-severity vulnerability in n/a, published on 19 Nov 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2011-2486 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-2486/ (Markdown: https://insights.sbomify.com/CVE-2011-2486/index.md)","id":"CVE-2011-2486","markdown":"https://insights.sbomify.com/CVE-2011-2486/index.md","name":"CVE-2011-2486","record":{"aliases":["GHSA-fvm8-v4j9-jgp3","RHSA-2012:1459","openSUSE-SU-2024:10270-1"],"analysis":{"component_type":"browser","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Browser plugin wrapper","requires_auth":"none","summary":"Remote attackers can bypass Private Browsing restrictions in Firefox plugins like Flash due to improper variable handling in nspluginwrapper.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"nspluginwrapper","vendor":"nspluginwrapper"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"nspluginwrapper before 1.4.4 does not properly provide access to NPNVprivateModeBool variable settings, which could prevent Firefox plugins from determining if they should run in Private Browsing mode and allow remote attackers to bypass intended access restrictions, as demonstrated using Flash.","ecosystems":["Red Hat:enterprise_linux:6::client","Red Hat:enterprise_linux:6::computenode","Red Hat:enterprise_linux:6::server","Red Hat:enterprise_linux:6::workstation","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in n/a","id":"CVE-2011-2486","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2011"},"n_packages":9,"n_references":6,"next":{"headline":"Use of a Broken or Risky Cryptographic Algorithm in Apache WSS4J","id":"CVE-2011-2487"},"packages":[{"ecosystem":"Red Hat:enterprise_linux:6::client","fixed":["0:1.4.4-1.el6_3"],"introduced":["0"],"last_affected":[],"package":"nspluginwrapper","purl":"pkg:rpm/redhat/nspluginwrapper","source":"RHSA-2012:1459"},{"ecosystem":"Red Hat:enterprise_linux:6::client","fixed":["0:1.4.4-1.el6_3"],"introduced":["0"],"last_affected":[],"package":"nspluginwrapper-debuginfo","purl":"pkg:rpm/redhat/nspluginwrapper-debuginfo","source":"RHSA-2012:1459"},{"ecosystem":"Red Hat:enterprise_linux:6::computenode","fixed":["0:1.4.4-1.el6_3"],"introduced":["0"],"last_affected":[],"package":"nspluginwrapper","purl":"pkg:rpm/redhat/nspluginwrapper","source":"RHSA-2012:1459"},{"ecosystem":"Red Hat:enterprise_linux:6::computenode","fixed":["0:1.4.4-1.el6_3"],"introduced":["0"],"last_affected":[],"package":"nspluginwrapper-debuginfo","purl":"pkg:rpm/redhat/nspluginwrapper-debuginfo","source":"RHSA-2012:1459"},{"ecosystem":"Red Hat:enterprise_linux:6::server","fixed":["0:1.4.4-1.el6_3"],"introduced":["0"],"last_affected":[],"package":"nspluginwrapper","purl":"pkg:rpm/redhat/nspluginwrapper","source":"RHSA-2012:1459"},{"ecosystem":"Red Hat:enterprise_linux:6::server","fixed":["0:1.4.4-1.el6_3"],"introduced":["0"],"last_affected":[],"package":"nspluginwrapper-debuginfo","purl":"pkg:rpm/redhat/nspluginwrapper-debuginfo","source":"RHSA-2012:1459"},{"ecosystem":"Red Hat:enterprise_linux:6::workstation","fixed":["0:1.4.4-1.el6_3"],"introduced":["0"],"last_affected":[],"package":"nspluginwrapper","purl":"pkg:rpm/redhat/nspluginwrapper","source":"RHSA-2012:1459"},{"ecosystem":"Red Hat:enterprise_linux:6::workstation","fixed":["0:1.4.4-1.el6_3"],"introduced":["0"],"last_affected":[],"package":"nspluginwrapper-debuginfo","purl":"pkg:rpm/redhat/nspluginwrapper-debuginfo","source":"RHSA-2012:1459"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.4.4-16.6"],"introduced":["0"],"last_affected":[],"package":"nspluginwrapper","purl":"pkg:rpm/opensuse/nspluginwrapper\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10270-1"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2011-2485"},"products":["n/a"],"published":"2012-11-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can bypass Private Browsing restrictions in Firefox plugins like Flash due to improper variable handling in nspluginwrapper.","url":"https://insights.sbomify.com/CVE-2011-2486/"}