# CVE-2011-2487: Use of a Broken or Risky Cryptographic Algorithm in Apache WSS4J

> A Bleichenbacher attack on PKCS#1 v1.5 key transport in JBossWS and WSS4J allows attackers to decrypt sensitive data.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2020
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-4qqf-hmv6-r6wh

## What is CVE-2011-2487?

CVE-2011-2487 is a medium-severity vulnerability in Apache Cxf, published on 11 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The implementations of PKCS#1 v1.5 key transport mechanism for XMLEncryption in JBossWS and Apache WSS4J before 1.6.5 is susceptible to a Bleichenbacher attack.

Weakness: CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2011-2487?

4 open source packages ship an affected version, including org.apache.ws.security:wss4j and wss4j:wss4j. It affects 10 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.ws.security:wss4j` | Maven | All versions | 1.6.5 |
| `org.apache.ws.security:wss4j` | Maven | All versions | 1.6.5 |
| `wss4j:wss4j` | Maven | All versions | 1.6.5 |
| `wss4j:wss4j` | Maven | All versions | 1.6.5 |

Products: Apache Cxf, Apache Wss4j, Redhat Jboss Business Rules Management System, Redhat Jboss Enterprise Application Platform, Redhat Jboss Enterprise Application Platform Text-Only Advisories, Redhat Jboss Enterprise Soa Platform, Redhat Jboss Enterprise Web Platform, Redhat Jboss Middleware Text-Only Advisories, Redhat Jboss Portal, Redhat Jboss Web Services.

## How do I fix CVE-2011-2487?

Upgrade org.apache.ws.security:wss4j to 1.6.5 or later.

## Is CVE-2011-2487 being exploited?

There is no known exploitation of CVE-2011-2487 in the wild and no public exploit code.

## Other vulnerabilities in Apache Cxf

- [CVE-2012-2379](https://insights.sbomify.com/CVE-2012-2379/): XML Signature/Encryption Not Validated in Apache CXF (critical 10.0)
- [CVE-2026-66909](https://insights.sbomify.com/CVE-2026-66909/): Apache CXF: Unsafe deserialization of inbound JMS ObjectMessage (critical 9.8)
- [CVE-2026-68079](https://insights.sbomify.com/CVE-2026-68079/): Apache CXF: DefaultEncryptingCodeDataProvider allows unlimited authorization code replay (critical 9.8)
- [CVE-2026-50628](https://insights.sbomify.com/CVE-2026-50628/): Apache CXF: OAuth2: Inverted IP Binding Check Defeats Security Control (critical 9.8)
- [CVE-2025-48913](https://insights.sbomify.com/CVE-2025-48913/): Apache CXF: Untrusted JMS configuration can lead to RCE (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-2487 and fix it if it is affected.

What it is: CVE-2011-2487 is a medium-severity vulnerability in Apache Cxf, published on 11 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-2487 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.ws.security:wss4j (Maven): affected all versions; fixed in 1.6.5
- org.apache.ws.security:wss4j (Maven): affected all versions; fixed in 1.6.5
- wss4j:wss4j (Maven): affected all versions; fixed in 1.6.5
- wss4j:wss4j (Maven): affected all versions; fixed in 1.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-2487/ (Markdown: https://insights.sbomify.com/CVE-2011-2487/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-2487
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-2487
- OSV: https://osv.dev/vulnerability/CVE-2011-2487

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-2487/
Summaries are generated and may contain mistakes; the official description above is the record.
