CVE-2011-2505 phpMyAdmin remote variable manipulation
Remote attackers can modify PHP session variables via crafted requests in phpMyAdmin, potentially leading to privilege escalation or authentication bypass.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2011-2505?
CVE-2011-2505 is a medium-severity code injection vulnerability in Phpmyadmin Phpmyadmin, published on 14 Jul 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 assigns values to arbitrary parameters referenced in the query string, which allows remote attackers to modify the SESSION superglobal array via a crafted request, related to a "remote variable manipulation vulnerability."
Weakness: CWE-94
Which versions are affected by CVE-2011-2505?
4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 3.0 | 3.3.10.2 |
phpmyadmin/phpmyadmin Packagist | From 3.0 | 3.3.10.2 |
phpmyadmin/phpmyadmin Packagist | From 3.4 | 3.4.3.1 |
phpmyadmin/phpmyadmin Packagist | From 3.4 | 3.4.3.1 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2011-2505?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 3.3.10.2 or 3.4.3.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2011-2505 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-2505 exists.
Public exploit code: 2 Exploit-DB entries.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as DEBIAN-CVE-2011-2505, GHSA-vqcm-r62w-w437.