{"answers":{"affected":"4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-2505 exists.","fix":"Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 3.3.10.2 or 3.4.3.1.","what":"CVE-2011-2505 is a medium-severity code injection vulnerability in Phpmyadmin Phpmyadmin, published on 14 Jul 2011. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2011-2505 and fix it if it is affected.\n\nWhat it is: CVE-2011-2505 is a medium-severity code injection vulnerability in Phpmyadmin Phpmyadmin, published on 14 Jul 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-2505 exists.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 3.0; fixed in 3.3.10.2\n- phpmyadmin/phpmyadmin (Packagist): affected from 3.0; fixed in 3.3.10.2\n- phpmyadmin/phpmyadmin (Packagist): affected from 3.4; fixed in 3.4.3.1\n- phpmyadmin/phpmyadmin (Packagist): affected from 3.4; fixed in 3.4.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-2505/ (Markdown: https://insights.sbomify.com/CVE-2011-2505/index.md)","id":"CVE-2011-2505","markdown":"https://insights.sbomify.com/CVE-2011-2505/index.md","name":"CVE-2011-2505","record":{"aliases":["DEBIAN-CVE-2011-2505","GHSA-vqcm-r62w-w437"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyAdmin","requires_auth":"none","summary":"Remote attackers can modify PHP session variables via crafted requests in phpMyAdmin, potentially leading to privilege escalation or authentication bypass.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":6.4,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 assigns values to arbitrary parameters referenced in the query string, which allows remote attackers to modify the SESSION superglobal array via a crafted request, related to a \"remote variable manipulation vulnerability.\"","ecosystems":["Packagist"],"exploits":{"exploitdb":2,"first_seen":"2011-07-08","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2011-07-08","kind":"exploitdb","ref":"17510","stars":null,"title":"phpMyAdmin3 (pma3) - Remote Code Execution"},{"date":"2011-07-09","kind":"exploitdb","ref":"17514","stars":null,"title":"phpMyAdmin 3.x - Swekey Remote Code Injection"}],"tier":"weaponised"},"has_fix":true,"headline":"phpMyAdmin remote variable manipulation","id":"CVE-2011-2505","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyadmin:phpmyadmin","products":["phpmyadmin:phpmyadmin"],"type":"code_injection","year":"2011"},"n_packages":4,"n_references":19,"next":{"headline":"phpMyAdmin vulnerable to static code injection","id":"CVE-2011-2506"},"packages":[{"ecosystem":"Packagist","fixed":["3.3.10.2"],"introduced":["3.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-vqcm-r62w-w437"},{"ecosystem":"Packagist","fixed":["3.3.10.2"],"introduced":["3.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-vqcm-r62w-w437"},{"ecosystem":"Packagist","fixed":["3.4.3.1"],"introduced":["3.4"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-vqcm-r62w-w437"},{"ecosystem":"Packagist","fixed":["3.4.3.1"],"introduced":["3.4"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-vqcm-r62w-w437"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2011-2504"},"products":["n/a"],"published":"2011-07-14","related":[{"cvss_score":10,"headline":"Misconfiguration in n/a","id":"CVE-2008-7251","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"phpMyAdmin unsafely handles temporary files","id":"CVE-2008-7252","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2007-0203","kev_date_added":null,"published":"2007-01-11"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2004-1147","kev_date_added":null,"published":"2004-12-15"},{"cvss_score":9.8,"headline":"phpmyadmin contains SQL Injection vulnerability","id":"CVE-2020-22452","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-11768","kev_date_added":null,"published":"2019-06-05"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-6798","kev_date_added":null,"published":"2019-01-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can modify PHP session variables via crafted requests in phpMyAdmin, potentially leading to privilege escalation or authentication bypass.","url":"https://insights.sbomify.com/CVE-2011-2505/"}