# CVE-2011-2505: phpMyAdmin remote variable manipulation

> Remote attackers can modify PHP session variables via crafted requests in phpMyAdmin, potentially leading to privilege escalation or authentication bypass.

- **Severity:** Medium 6.4 (`AV:N/AC:L/Au:N/C:N/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2011
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2011-2505, GHSA-vqcm-r62w-w437

## What is CVE-2011-2505?

CVE-2011-2505 is a medium-severity code injection vulnerability in Phpmyadmin Phpmyadmin, published on 14 Jul 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 assigns values to arbitrary parameters referenced in the query string, which allows remote attackers to modify the SESSION superglobal array via a crafted request, related to a "remote variable manipulation vulnerability."

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2011-2505?

4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 3.0 | 3.3.10.2 |
| `phpmyadmin/phpmyadmin` | Packagist | From 3.0 | 3.3.10.2 |
| `phpmyadmin/phpmyadmin` | Packagist | From 3.4 | 3.4.3.1 |
| `phpmyadmin/phpmyadmin` | Packagist | From 3.4 | 3.4.3.1 |

Products: Phpmyadmin Phpmyadmin.

## How do I fix CVE-2011-2505?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 3.3.10.2 or 3.4.3.1.

## Is CVE-2011-2505 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-2505 exists.

Public exploit code:

- phpMyAdmin3 (pma3) - Remote Code Execution (exploitdb)
- phpMyAdmin 3.x - Swekey Remote Code Injection (exploitdb)

## Other vulnerabilities in Phpmyadmin Phpmyadmin

- [CVE-2008-7251](https://insights.sbomify.com/CVE-2008-7251/): Misconfiguration in n/a (critical 10.0)
- [CVE-2008-7252](https://insights.sbomify.com/CVE-2008-7252/): phpMyAdmin unsafely handles temporary files (critical 10.0)
- [CVE-2007-0203](https://insights.sbomify.com/CVE-2007-0203/): Other in n/a (critical 10.0)
- [CVE-2004-1147](https://insights.sbomify.com/CVE-2004-1147/): Command injection in n/a (critical 10.0)
- [CVE-2020-22452](https://insights.sbomify.com/CVE-2020-22452/): phpmyadmin contains SQL Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-2505 and fix it if it is affected.

What it is: CVE-2011-2505 is a medium-severity code injection vulnerability in Phpmyadmin Phpmyadmin, published on 14 Jul 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-2505 exists.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 3.0; fixed in 3.3.10.2
- phpmyadmin/phpmyadmin (Packagist): affected from 3.0; fixed in 3.3.10.2
- phpmyadmin/phpmyadmin (Packagist): affected from 3.4; fixed in 3.4.3.1
- phpmyadmin/phpmyadmin (Packagist): affected from 3.4; fixed in 3.4.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-2505/ (Markdown: https://insights.sbomify.com/CVE-2011-2505/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-2505
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-2505
- OSV: https://osv.dev/vulnerability/CVE-2011-2505

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-2505/
Summaries are generated and may contain mistakes; the official description above is the record.
