CVE-2011-2506 phpMyAdmin vulnerable to static code injection
Remote attackers can inject static code into phpMyAdmin by modifying session data, potentially leading to arbitrary code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2011-2506?
CVE-2011-2506 is a high-severity code injection vulnerability in Phpmyadmin Phpmyadmin, published on 14 Jul 2011. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
setup/lib/ConfigGenerator.class.php in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 does not properly restrict the presence of comment closing delimiters, which allows remote attackers to conduct static code injection attacks by leveraging the ability to modify the SESSION superglobal array.
Weakness: CWE-94
Which versions are affected by CVE-2011-2506?
4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 3.0 | 3.3.10.2 |
phpmyadmin/phpmyadmin Packagist | From 3.0 | 3.3.10.2 |
phpmyadmin/phpmyadmin Packagist | From 3.4 | 3.4.3.1 |
phpmyadmin/phpmyadmin Packagist | From 3.4 | 3.4.3.1 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2011-2506?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 3.3.10.2 or 3.4.3.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2011-2506 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-2506 exists.
Public exploit code: 2 Exploit-DB entries.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as DEBIAN-CVE-2011-2506, GHSA-p6h7-29r2-g88f.