# CVE-2011-2506: phpMyAdmin vulnerable to static code injection

> Remote attackers can inject static code into phpMyAdmin by modifying session data, potentially leading to arbitrary code execution.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2011
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2011-2506, GHSA-p6h7-29r2-g88f

## What is CVE-2011-2506?

CVE-2011-2506 is a high-severity code injection vulnerability in Phpmyadmin Phpmyadmin, published on 14 Jul 2011. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

setup/lib/ConfigGenerator.class.php in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 does not properly restrict the presence of comment closing delimiters, which allows remote attackers to conduct static code injection attacks by leveraging the ability to modify the SESSION superglobal array.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2011-2506?

4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 3.0 | 3.3.10.2 |
| `phpmyadmin/phpmyadmin` | Packagist | From 3.0 | 3.3.10.2 |
| `phpmyadmin/phpmyadmin` | Packagist | From 3.4 | 3.4.3.1 |
| `phpmyadmin/phpmyadmin` | Packagist | From 3.4 | 3.4.3.1 |

Products: Phpmyadmin Phpmyadmin.

## How do I fix CVE-2011-2506?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 3.3.10.2 or 3.4.3.1.

## Is CVE-2011-2506 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-2506 exists.

Public exploit code:

- phpMyAdmin3 (pma3) - Remote Code Execution (exploitdb)
- phpMyAdmin 3.x - Swekey Remote Code Injection (exploitdb)

## Other vulnerabilities in Phpmyadmin Phpmyadmin

- [CVE-2008-7251](https://insights.sbomify.com/CVE-2008-7251/): Misconfiguration in n/a (critical 10.0)
- [CVE-2008-7252](https://insights.sbomify.com/CVE-2008-7252/): phpMyAdmin unsafely handles temporary files (critical 10.0)
- [CVE-2007-0203](https://insights.sbomify.com/CVE-2007-0203/): Other in n/a (critical 10.0)
- [CVE-2004-1147](https://insights.sbomify.com/CVE-2004-1147/): Command injection in n/a (critical 10.0)
- [CVE-2020-22452](https://insights.sbomify.com/CVE-2020-22452/): phpmyadmin contains SQL Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-2506 and fix it if it is affected.

What it is: CVE-2011-2506 is a high-severity code injection vulnerability in Phpmyadmin Phpmyadmin, published on 14 Jul 2011. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-2506 exists.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 3.0; fixed in 3.3.10.2
- phpmyadmin/phpmyadmin (Packagist): affected from 3.0; fixed in 3.3.10.2
- phpmyadmin/phpmyadmin (Packagist): affected from 3.4; fixed in 3.4.3.1
- phpmyadmin/phpmyadmin (Packagist): affected from 3.4; fixed in 3.4.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-2506/ (Markdown: https://insights.sbomify.com/CVE-2011-2506/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-2506
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-2506
- OSV: https://osv.dev/vulnerability/CVE-2011-2506

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-2506/
Summaries are generated and may contain mistakes; the official description above is the record.
