CVE-2011-2508 phpMyAdmin Directory Traversal vulnerability
Authenticated attackers can execute arbitrary local files via path traversal in phpMyAdmin when MIME transformation is enabled.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2011-2508?
CVE-2011-2508 is a medium-severity path traversal vulnerability in Phpmyadmin Phpmyadmin, published on 14 Jul 2011. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Directory traversal vulnerability in libraries/display_tbl.lib.php in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1, when a certain MIME transformation feature is enabled, allows remote authenticated users to include and execute arbitrary local files via a .. (dot dot) in a GLOBALS[mime_map][$meta->name][transformation] parameter.
Weakness: CWE-22
Which versions are affected by CVE-2011-2508?
4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 3.3.0 | 3.3.10.2 |
phpmyadmin/phpmyadmin Packagist | From 3.3.0 | 3.3.10.2 |
phpmyadmin/phpmyadmin Packagist | From 3.4.0 | 3.4.3.1 |
phpmyadmin/phpmyadmin Packagist | From 3.4.0 | 3.4.3.1 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2011-2508?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 3.3.10.2 or 3.4.3.1.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2011-2508 being exploited?
There is no known exploitation of CVE-2011-2508 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as DEBIAN-CVE-2011-2508, GHSA-q6vw-39cg-wjjf.