# CVE-2011-2509: Joomla! vulnerable to Cross-site Scripting

> Remote attackers can inject arbitrary web script or HTML into Joomla! via various query string parameters, requiring user interaction to execute.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jul 2011
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-vcq7-x4wr-w2mj

## What is CVE-2011-2509?

CVE-2011-2509 is a medium-severity cross-site scripting vulnerability in Joomla Joomla\!, published on 27 Jul 2011. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in Joomla! before 1.6.4 allow remote attackers to inject arbitrary web script or HTML via (1) the query string to the com_contact component, as demonstrated by the Itemid parameter to index.php; (2) the query string to the com_content component, as demonstrated by the filter_order parameter to index.php; (3) the query string to the com_newsfeeds component, as demonstrated by an arbitrary parameter to index.php; or (4) the option parameter in a reset.request action to index.php; and, when Internet Explorer or Konqueror is used, (5) allow remote attackers to inject arbitrary web script or HTML via the searchword parameter in a search action to index.php in the com_search component.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2011-2509?

2 open source packages ship an affected version, including joomla/joomla-cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joomla/joomla-cms` | Packagist | All versions | 1.6.4 |
| `joomla/joomla-cms` | Packagist | All versions | 1.6.4 |

Products: Joomla Joomla\!.

## How do I fix CVE-2011-2509?

Upgrade joomla/joomla-cms to 1.6.4 or later.

## Is CVE-2011-2509 being exploited?

There is no known exploitation of CVE-2011-2509 in the wild and no public exploit code.

## Other vulnerabilities in Joomla Joomla\!

- [CVE-2016-10033](https://insights.sbomify.com/CVE-2016-10033/): PHPMailer Command Injection (critical 9.8, exploited in the wild)
- [CVE-2023-23752](https://insights.sbomify.com/CVE-2023-23752/): Joomla! Improper Access Control (medium 5.3, exploited in the wild)
- [CVE-2026-48902](https://insights.sbomify.com/CVE-2026-48902/): Joomla! Core - [20260518] - Transport encryption downgrade for password and username reset links (critical 9.8)
- [CVE-2025-25226](https://insights.sbomify.com/CVE-2025-25226/): [20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package (critical 9.8)
- [CVE-2022-23795](https://insights.sbomify.com/CVE-2022-23795/): [20220303] - Core - User row are not bound to a authentication mechanism (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-2509 and fix it if it is affected.

What it is: CVE-2011-2509 is a medium-severity cross-site scripting vulnerability in Joomla Joomla\!, published on 27 Jul 2011. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2011-2509 in the wild and no public exploit code.

Affected packages and fixed versions:
- joomla/joomla-cms (Packagist): affected all versions; fixed in 1.6.4
- joomla/joomla-cms (Packagist): affected all versions; fixed in 1.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-2509/ (Markdown: https://insights.sbomify.com/CVE-2011-2509/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-2509
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-2509
- OSV: https://osv.dev/vulnerability/CVE-2011-2509

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-2509/
Summaries are generated and may contain mistakes; the official description above is the record.
