# CVE-2011-2526: Improper Input Validation in Apache Tomcat

> Local attackers can bypass file access restrictions or cause denial of service in Apache Tomcat when sendfile is enabled.

- **Severity:** Medium 4.4 (`AV:L/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2011
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-9ggm-7897-x4mg

## What is CVE-2011-2526?

CVE-2011-2526 is a medium-severity vulnerability in Apache Tomcat, published on 14 Jul 2011. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Apache Tomcat 5.5.x before 5.5.34, 6.x before 6.0.33, and 7.x before 7.0.19, when sendfile is enabled for the HTTP APR or HTTP NIO connector, does not validate certain request attributes, which allows local users to bypass intended file access restrictions or cause a denial of service (infinite loop or JVM crash) by leveraging an untrusted web application.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2011-2526?

6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | All versions | 5.5.34 |
| `org.apache.tomcat:tomcat` | Maven | All versions | 5.5.34 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.33 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.33 |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.0 | 7.0.19 |
| `org.apache.tomcat:tomcat` | Maven | From 7.0.0 | 7.0.19 |

Products: Apache Tomcat.

## How do I fix CVE-2011-2526?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 5.5.34, 6.0.33 or 7.0.19.

## Is CVE-2011-2526 being exploited?

There is no known exploitation of CVE-2011-2526 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-2526 and fix it if it is affected.

What it is: CVE-2011-2526 is a medium-severity vulnerability in Apache Tomcat, published on 14 Jul 2011. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-2526 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected all versions; fixed in 5.5.34
- org.apache.tomcat:tomcat (Maven): affected all versions; fixed in 5.5.34
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.33
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.33
- org.apache.tomcat:tomcat (Maven): affected from 7.0.0; fixed in 7.0.19
- org.apache.tomcat:tomcat (Maven): affected from 7.0.0; fixed in 7.0.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-2526/ (Markdown: https://insights.sbomify.com/CVE-2011-2526/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-2526
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-2526
- OSV: https://osv.dev/vulnerability/CVE-2011-2526

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-2526/
Summaries are generated and may contain mistakes; the official description above is the record.
