# CVE-2011-2687: Drupal Access Control Bypass

> Remote attackers can bypass node access restrictions to view unauthorized content due to missing database join clauses in Drupal 7.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2011
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-96vx-qf28-6f8m

## What is CVE-2011-2687?

CVE-2011-2687 is a high-severity missing authorization vulnerability in Drupal Drupal, published on 27 Jul 2011. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Drupal 7.x before 7.3 allows remote attackers to bypass intended node_access restrictions via vectors related to a listing that shows nodes but lacks a JOIN clause for the node table.

Weakness: CWE-264

## Which versions are affected by CVE-2011-2687?

2 open source packages ship an affected version, including drupal/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 7.0 | 7.3 |
| `drupal/core` | Packagist | From 7.0 | 7.3 |

Products: Drupal Drupal.

## How do I fix CVE-2011-2687?

Upgrade drupal/core to 7.3 or later.

## Is CVE-2011-2687 being exploited?

There is no known exploitation of CVE-2011-2687 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-2687 and fix it if it is affected.

What it is: CVE-2011-2687 is a high-severity missing authorization vulnerability in Drupal Drupal, published on 27 Jul 2011. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-2687 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 7.0; fixed in 7.3
- drupal/core (Packagist): affected from 7.0; fixed in 7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-2687/ (Markdown: https://insights.sbomify.com/CVE-2011-2687/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-2687
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-2687
- OSV: https://osv.dev/vulnerability/CVE-2011-2687

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-2687/
Summaries are generated and may contain mistakes; the official description above is the record.
