# CVE-2011-2718: phpMyAdmin Directory Traversal Vulnerability

> Authenticated users can exploit directory traversal in phpMyAdmin to include and execute arbitrary local files, leading to code execution or data disclosure.

- **Severity:** Medium 6.0 (`AV:N/AC:M/Au:S/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2011
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2011-2718, GHSA-xhqq-554j-p4x8

## What is CVE-2011-2718?

CVE-2011-2718 is a medium-severity path traversal vulnerability in Phpmyadmin Phpmyadmin, published on 1 Aug 2011. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Multiple directory traversal vulnerabilities in the relational schema implementation in phpMyAdmin 3.4.x before 3.4.3.2 allow remote authenticated users to include and execute arbitrary local files via directory traversal sequences in an export type field, related to (1) libraries/schema/User_Schema.class.php and (2) schema_export.php.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2011-2718?

2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 3.4 | 3.4.3.2 |
| `phpmyadmin/phpmyadmin` | Packagist | From 3.4 | 3.4.3.2 |

Products: Phpmyadmin Phpmyadmin.

## How do I fix CVE-2011-2718?

Upgrade phpmyadmin/phpmyadmin to 3.4.3.2 or later.

## Is CVE-2011-2718 being exploited?

There is no known exploitation of CVE-2011-2718 in the wild and no public exploit code.

## Other vulnerabilities in Phpmyadmin Phpmyadmin

- [CVE-2008-7251](https://insights.sbomify.com/CVE-2008-7251/): Misconfiguration in n/a (critical 10.0)
- [CVE-2008-7252](https://insights.sbomify.com/CVE-2008-7252/): phpMyAdmin unsafely handles temporary files (critical 10.0)
- [CVE-2007-0203](https://insights.sbomify.com/CVE-2007-0203/): Other in n/a (critical 10.0)
- [CVE-2004-1147](https://insights.sbomify.com/CVE-2004-1147/): Command injection in n/a (critical 10.0)
- [CVE-2020-22452](https://insights.sbomify.com/CVE-2020-22452/): phpmyadmin contains SQL Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-2718 and fix it if it is affected.

What it is: CVE-2011-2718 is a medium-severity path traversal vulnerability in Phpmyadmin Phpmyadmin, published on 1 Aug 2011. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-2718 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 3.4; fixed in 3.4.3.2
- phpmyadmin/phpmyadmin (Packagist): affected from 3.4; fixed in 3.4.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-2718/ (Markdown: https://insights.sbomify.com/CVE-2011-2718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-2718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-2718
- OSV: https://osv.dev/vulnerability/CVE-2011-2718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-2718/
Summaries are generated and may contain mistakes; the official description above is the record.
