CVE-2011-2730 Improper Neutralization of Directives in Dynamically Evaluated Code in Spring Framework
Remote attackers can obtain sensitive information via Expression Language injection in Spring Framework tags when EL support is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2011-2730?
CVE-2011-2730 is a high-severity vulnerability in n/a, published on 5 Dec 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
VMware SpringSource Spring Framework before 2.5.6.SEC03, 2.5.7.SR023, and 3.x before 3.0.6, when a container supports Expression Language (EL), evaluates EL expressions in tags twice, which allows remote attackers to obtain sensitive information via a (1) name attribute in a (a) spring:hasBindErrors tag; (2) path attribute in a (b) spring:bind or (c) spring:nestedpath tag; (3) arguments, (4) code, (5) text, (6) var, (7) scope, or (8) message attribute in a (d) spring:message or (e) spring:theme tag; or (9) var, (10) scope, or (11) value attribute in a (f) spring:transform tag, aka "Expression Language Injection."
Weakness: CWE-16
Which versions are affected by CVE-2011-2730?
6 open source packages ship an affected version, including org.springframework:spring-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework:spring-core Maven | All versions | 2.5.6.SEC03 |
org.springframework:spring-core Maven | All versions | 2.5.6.SEC03 |
org.springframework:spring-core Maven | From 2.5.7.SR0 | 2.5.7.SR023 |
org.springframework:spring-core Maven | From 2.5.7.SR0 | 2.5.7.SR023 |
org.springframework:spring-core Maven | From 3.0.0 | 3.0.6 |
org.springframework:spring-core Maven | From 3.0.0 | 3.0.6 |
Products include Springsource Spring Framework.
How do I fix CVE-2011-2730?
Upgrade org.springframework:spring-core to a fixed version for your release line: 2.5.6.SEC03, 2.5.7.SR023 or 3.0.6.
Is CVE-2011-2730 being exploited?
There is no known exploitation of CVE-2011-2730 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as CLSA-2026-1781052740, DSA-2504-1, GHSA-wv88-pf73-x22p.