# CVE-2011-2765: Insecure temporary file handling

> An attacker can overwrite arbitrary files via symlink attacks on insecurely handled PID files, potentially leading to privilege escalation.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-xrr4-74mc-rpjc, PYSEC-2018-99

## What is CVE-2011-2765?

CVE-2011-2765 is a high-severity path traversal vulnerability in n/a, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pyro before 3.15 unsafely handles pid files in temporary directory locations and opening the pid file as root. An attacker can use this flaw to overwrite arbitrary files via symlinks.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2011-2765?

3 open source packages ship an affected version, including pyro. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyro` | PyPI | All versions | 3.15 |
| `pyro` | PyPI | All versions | 3.15 |
| `pyro` | PyPI | All versions | 3.15 |

Products: Pyro Project Pyro.

## How do I fix CVE-2011-2765?

Upgrade pyro to 3.15 or later.

## Is CVE-2011-2765 being exploited?

There is no known exploitation of CVE-2011-2765 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-2765 and fix it if it is affected.

What it is: CVE-2011-2765 is a high-severity path traversal vulnerability in n/a, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-2765 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyro (PyPI): affected all versions; fixed in 3.15
- pyro (PyPI): affected all versions; fixed in 3.15
- pyro (PyPI): affected all versions; fixed in 3.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-2765/ (Markdown: https://insights.sbomify.com/CVE-2011-2765/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-2765
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-2765
- OSV: https://osv.dev/vulnerability/CVE-2011-2765

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-2765/
Summaries are generated and may contain mistakes; the official description above is the record.
