# CVE-2011-2894: Spring Framework and Spring Security vulnerable to Deserialization of Untrusted Data

> Remote attackers can execute arbitrary code by sending malicious serialized objects to applications using vulnerable Spring Framework or Spring Security versions.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Oct 2011
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-f866-m9mv-2xr3

## What is CVE-2011-2894?

CVE-2011-2894 is a medium-severity unsafe deserialization vulnerability in Vmware Spring Framework, published on 4 Oct 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring Framework 3.0.0 through 3.0.5, Spring Security 3.0.0 through 3.0.5 and 2.0.0 through 2.0.6, and possibly other versions deserialize objects from untrusted sources, which allows remote attackers to bypass intended security restrictions and execute untrusted code by (1) serializing a java.lang.Proxy instance and using InvocationHandler, or (2) accessing internal AOP interfaces, as demonstrated using deserialization of a DefaultListableBeanFactory instance to execute arbitrary commands via the java.lang.Runtime class.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2011-2894?

6 open source packages ship an affected version, including org.springframework.security:spring-security-core and org.springframework:spring-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.security:spring-security-core` | Maven | From 2.0.0 | 2.0.7 |
| `org.springframework.security:spring-security-core` | Maven | From 2.0.0 | 2.0.7 |
| `org.springframework.security:spring-security-core` | Maven | From 3.0.0 | 3.0.6 |
| `org.springframework.security:spring-security-core` | Maven | From 3.0.0 | 3.0.6 |
| `org.springframework:spring-core` | Maven | From 3.0.0 | 3.0.6 |
| `org.springframework:spring-core` | Maven | From 3.0.0 | 3.0.6 |

Products: Vmware Spring Framework, Vmware Spring Security.

## How do I fix CVE-2011-2894?

Upgrade org.springframework.security:spring-security-core to a fixed version for your release line: 2.0.7 or 3.0.6.

## Is CVE-2011-2894 being exploited?

There is no known exploitation of CVE-2011-2894 in the wild and no public exploit code.

Public exploit code:

- Exploit PoC for Spring RCE issue (CVE-2011-2894) (github_poc): https://github.com/pwntester/SpringBreaker

## Other vulnerabilities in Vmware Spring Framework

- [CVE-2026-47884](https://insights.sbomify.com/CVE-2026-47884/): Spring Framework Improper Path Limitation in XsltView (critical 9.8)
- [CVE-2026-47890](https://insights.sbomify.com/CVE-2026-47890/): Spring Framework Server Sent Event stream corruption while rendering fragments (critical 9.8)
- [CVE-2026-47891](https://insights.sbomify.com/CVE-2026-47891/): Spring Framework maxInMemorySize Bypassed in Jaxb2Decoder (critical 9.8)
- [CVE-2026-47892](https://insights.sbomify.com/CVE-2026-47892/): Spring Framework Header Predicate Bypass in WebFlux Functional Endpoints (critical 9.8)
- [CVE-2026-59313](https://insights.sbomify.com/CVE-2026-59313/): Server Sent Event stream corruption in Spring MVC functional web framework (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-2894 and fix it if it is affected.

What it is: CVE-2011-2894 is a medium-severity unsafe deserialization vulnerability in Vmware Spring Framework, published on 4 Oct 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-2894 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.security:spring-security-core (Maven): affected from 2.0.0; fixed in 2.0.7
- org.springframework.security:spring-security-core (Maven): affected from 2.0.0; fixed in 2.0.7
- org.springframework.security:spring-security-core (Maven): affected from 3.0.0; fixed in 3.0.6
- org.springframework.security:spring-security-core (Maven): affected from 3.0.0; fixed in 3.0.6
- org.springframework:spring-core (Maven): affected from 3.0.0; fixed in 3.0.6
- org.springframework:spring-core (Maven): affected from 3.0.0; fixed in 3.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-2894/ (Markdown: https://insights.sbomify.com/CVE-2011-2894/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-2894
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-2894
- OSV: https://osv.dev/vulnerability/CVE-2011-2894

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-2894/
Summaries are generated and may contain mistakes; the official description above is the record.
