CVE-2011-2931 actionpack Cross-site Scripting vulnerability

Medium 4.3 Published Updated

Remote attackers can inject arbitrary web script or HTML via a tag with an invalid name in the strip_tags helper, affecting Ruby on Rails applications.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2011-2931?

CVE-2011-2931 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 29 Aug 2011. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in the strip_tags helper in actionpack/lib/action_controller/vendor/html-scanner/html/node.rb in Ruby on Rails before 2.3.13, 3.0.x before 3.0.10, and 3.1.x before 3.1.0.rc5 allows remote attackers to inject arbitrary web script or HTML via a tag with an invalid name.

Weakness: CWE-79

Which versions are affected by CVE-2011-2931?

4 open source packages ship an affected version, including actionpack. It affects 2 products.

PackageAffectedFixed in
actionpack RubyGemsFrom 2.0.02.3.13
actionpack RubyGemsFrom 2.0.02.3.13
actionpack RubyGemsFrom 3.0.03.0.10
actionpack RubyGemsFrom 3.0.03.0.10

Products include Rubyonrails Rails, Rubyonrails Ruby on Rails.

How do I fix CVE-2011-2931?

Upgrade actionpack to a fixed version for your release line: 2.3.13 or 3.0.10.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2011-2931 being exploited?

There is no known exploitation of CVE-2011-2931 in the wild and no public exploit code.

All Rubyonrails Rails vulnerabilities

Sources

Also known as DEBIAN-CVE-2011-2931, GHSA-v5jg-558j-q67c.

Is CVE-2011-2931 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free