# CVE-2011-2931: actionpack Cross-site Scripting vulnerability

> Remote attackers can inject arbitrary web script or HTML via a tag with an invalid name in the strip_tags helper, affecting Ruby on Rails applications.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Aug 2011
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2011-2931, GHSA-v5jg-558j-q67c

## What is CVE-2011-2931?

CVE-2011-2931 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 29 Aug 2011. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the strip_tags helper in actionpack/lib/action_controller/vendor/html-scanner/html/node.rb in Ruby on Rails before 2.3.13, 3.0.x before 3.0.10, and 3.1.x before 3.1.0.rc5 allows remote attackers to inject arbitrary web script or HTML via a tag with an invalid name.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2011-2931?

4 open source packages ship an affected version, including actionpack. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | From 2.0.0 | 2.3.13 |
| `actionpack` | RubyGems | From 2.0.0 | 2.3.13 |
| `actionpack` | RubyGems | From 3.0.0 | 3.0.10 |
| `actionpack` | RubyGems | From 3.0.0 | 3.0.10 |

Products: Rubyonrails Rails, Rubyonrails Ruby on Rails.

## How do I fix CVE-2011-2931?

Upgrade actionpack to a fixed version for your release line: 2.3.13 or 3.0.10.

## Is CVE-2011-2931 being exploited?

There is no known exploitation of CVE-2011-2931 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-2931 and fix it if it is affected.

What it is: CVE-2011-2931 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 29 Aug 2011. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2011-2931 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionpack (RubyGems): affected from 2.0.0; fixed in 2.3.13
- actionpack (RubyGems): affected from 2.0.0; fixed in 2.3.13
- actionpack (RubyGems): affected from 3.0.0; fixed in 3.0.10
- actionpack (RubyGems): affected from 3.0.0; fixed in 3.0.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-2931/ (Markdown: https://insights.sbomify.com/CVE-2011-2931/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-2931
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-2931
- OSV: https://osv.dev/vulnerability/CVE-2011-2931

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-2931/
Summaries are generated and may contain mistakes; the official description above is the record.
