CVE-2011-2935 Elgg Reflected XSS Vulnerability
Medium 6.1
Published
Updated
Check this codebase for CVE-2011-2935 and fix it if it is affected.
What it is: CVE-2011-2935 is a medium-severity vulnerability in Elgg, published on 12 Nov 2019.
Exploitation: There is no known exploitation of CVE-2011-2935 in the wild and no public exploit code.
Affected packages and fixed versions:
- elgg/elgg (Packagist): affected all versions; fixed in 1.7.11
- elgg/elgg (Packagist): affected all versions; fixed in 1.7.11
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2011-2935/ (Markdown: https://insights.sbomify.com/CVE-2011-2935/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2011-2935?
CVE-2011-2935 is a medium-severity vulnerability in Elgg, published on 12 Nov 2019.
Official description
Elgg through 1.7.10 has XSS
Weakness: CWE-79
Which versions are affected by CVE-2011-2935?
2 open source packages ship an affected version, including elgg/elgg. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
elgg/elgg Packagist | All versions | 1.7.11 |
elgg/elgg Packagist | All versions | 1.7.11 |
Products include Elgg Elgg.
How do I fix CVE-2011-2935?
Upgrade elgg/elgg to 1.7.11 or later.
Is CVE-2011-2935 being exploited?
There is no known exploitation of CVE-2011-2935 in the wild and no public exploit code.
Other vulnerabilities in Elgg
Sources
Also known as GHSA-mcfm-j5g6-w26f.