# CVE-2011-2935: Elgg Reflected XSS Vulnerability


- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 12 Nov 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-mcfm-j5g6-w26f

## What is CVE-2011-2935?

CVE-2011-2935 is a medium-severity vulnerability in Elgg, published on 12 Nov 2019. 

### Official description

Elgg through 1.7.10 has XSS

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2011-2935?

2 open source packages ship an affected version, including elgg/elgg. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `elgg/elgg` | Packagist | All versions | 1.7.11 |
| `elgg/elgg` | Packagist | All versions | 1.7.11 |

Products: Elgg Elgg.

## How do I fix CVE-2011-2935?

Upgrade elgg/elgg to 1.7.11 or later.

## Is CVE-2011-2935 being exploited?

There is no known exploitation of CVE-2011-2935 in the wild and no public exploit code.

## Other vulnerabilities in Elgg

- [CVE-2011-2936](https://insights.sbomify.com/CVE-2011-2936/): SQL injection in Elgg (critical 9.8)
- [CVE-2021-4072](https://insights.sbomify.com/CVE-2021-4072/): Cross-site Scripting (XSS) - Stored in elgg/elgg (critical 9.0)
- [CVE-2012-6562](https://insights.sbomify.com/CVE-2012-6562/): Missing authorization in n/a (medium 6.8)
- [CVE-2019-11016](https://insights.sbomify.com/CVE-2019-11016/): Elgg open redirect (medium 6.1)
- [CVE-2021-3980](https://insights.sbomify.com/CVE-2021-3980/): Exposure of Private Personal Information to an Unauthorized Actor in elgg/elgg (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-2935 and fix it if it is affected.

What it is: CVE-2011-2935 is a medium-severity vulnerability in Elgg, published on 12 Nov 2019. 
Exploitation: There is no known exploitation of CVE-2011-2935 in the wild and no public exploit code.

Affected packages and fixed versions:
- elgg/elgg (Packagist): affected all versions; fixed in 1.7.11
- elgg/elgg (Packagist): affected all versions; fixed in 1.7.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-2935/ (Markdown: https://insights.sbomify.com/CVE-2011-2935/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-2935
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-2935
- OSV: https://osv.dev/vulnerability/CVE-2011-2935

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-2935/
Summaries are generated and may contain mistakes; the official description above is the record.
