# CVE-2011-3187: actionpack Improper Input Validation vulnerability

> Remote attackers can inject arbitrary text into logs or bypass address parsing via crafted X-Forwarded-For headers in Ruby on Rails.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2011
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2011-3187, GHSA-3vfw-7rcp-3xgm

## What is CVE-2011-3187?

CVE-2011-3187 is a medium-severity vulnerability in Rubyonrails Rails, published on 29 Aug 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The to_s method in actionpack/lib/action_dispatch/middleware/remote_ip.rb in Ruby on Rails 3.0.5 does not validate the X-Forwarded-For header in requests from IP addresses on a Class C network, which might allow remote attackers to inject arbitrary text into log files or bypass intended address parsing via a crafted header.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2011-3187?

2 open source packages ship an affected version, including actionpack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | From 2.3.0 | 2.3.13 |
| `actionpack` | RubyGems | From 2.3.0 | 2.3.13 |

Products: Rubyonrails Rails.

## How do I fix CVE-2011-3187?

Upgrade actionpack to 2.3.13 or later.

## Is CVE-2011-3187 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-3187 exists.

Public exploit code:

- Ruby on Rails 3.0.5 - 'WEBrick::HTTPRequest' Module HTTP Header Injection (exploitdb)

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-3187 and fix it if it is affected.

What it is: CVE-2011-3187 is a medium-severity vulnerability in Rubyonrails Rails, published on 29 Aug 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-3187 exists.

Affected packages and fixed versions:
- actionpack (RubyGems): affected from 2.3.0; fixed in 2.3.13
- actionpack (RubyGems): affected from 2.3.0; fixed in 2.3.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-3187/ (Markdown: https://insights.sbomify.com/CVE-2011-3187/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-3187
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-3187
- OSV: https://osv.dev/vulnerability/CVE-2011-3187

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-3187/
Summaries are generated and may contain mistakes; the official description above is the record.
