CVE-2011-3190 Apache Tomcat Allows Remote Attackers to Spoof AJP Requests
Remote attackers can bypass authentication and access sensitive information by spoofing AJP requests in Apache Tomcat.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2011-3190?
CVE-2011-3190 is a high-severity authentication bypass vulnerability in Apache Tomcat, published on 31 Aug 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Certain AJP protocol connector implementations in Apache Tomcat 7.0.0 through 7.0.20, 6.0.0 through 6.0.33, 5.5.0 through 5.5.33, and possibly other versions allow remote attackers to spoof AJP requests, bypass authentication, and obtain sensitive information by causing the connector to interpret a request body as a new request.
Weakness: CWE-264
Which versions are affected by CVE-2011-3190?
6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 5.0.0 | 5.5.34 |
org.apache.tomcat:tomcat Maven | From 5.0.0 | 5.5.34 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.34 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.34 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.21 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.21 |
Products include Apache Tomcat.
How do I fix CVE-2011-3190?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 5.5.34, 6.0.34 or 7.0.21.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2011-3190 being exploited?
There is no known exploitation of CVE-2011-3190 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-c38m-v4m2-524v.