CVE-2011-3587 Zope Command Execution Vulnerability

Critical 9.3 Published Updated

Remote attackers can execute arbitrary commands in Zope and Plone applications via Python module injection in OFS/misc_.py.

Exploited in the wild
Not known
Login needed
Not stated
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2011-3587?

CVE-2011-3587 is a critical code injection vulnerability in Plone Plone, published on 10 Oct 2011. It can be exploited over the network, with no action from the victim.

Official description

Unspecified vulnerability in Zope 2.12.x and 2.13.x, as used in Plone 4.0.x through 4.0.9, 4.1, and 4.2 through 4.2a2, allows remote attackers to execute arbitrary commands via vectors related to the p_ class in OFS/misc_.py and the use of Python modules.

Which versions are affected by CVE-2011-3587?

5 open source packages ship an affected version, including zope2. It affects 2 products.

PackageAffectedFixed in
zope2 PyPIFrom 2.12.02.12.20, 2.13.10
zope2 PyPIFrom 2.12.02.12.20
zope2 PyPIFrom 2.12.02.12.20
zope2 PyPIFrom 2.13.02.13.10
zope2 PyPIFrom 2.13.02.13.10

Products include Plone Plone, Zope Zope.

How do I fix CVE-2011-3587?

Upgrade zope2 to a fixed version for your release line: 2.12.20 or 2.13.10.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2011-3587 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-3587 exists.

Public exploit code: 1 Metasploit module and 1 Exploit-DB entry.

All Plone Plone vulnerabilities

Sources

Also known as GHSA-8w48-m6hx-rjw2, PYSEC-2026-1067.

Is CVE-2011-3587 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free