# CVE-2011-3587: Zope Command Execution Vulnerability

> Remote attackers can execute arbitrary commands in Zope and Plone applications via Python module injection in OFS/misc_.py.

- **Severity:** Critical 9.3 (`AV:N/AC:M/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2011
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-8w48-m6hx-rjw2, PYSEC-2026-1067

## What is CVE-2011-3587?

CVE-2011-3587 is a critical code injection vulnerability in Plone Plone, published on 10 Oct 2011. It can be exploited over the network, with no action from the victim.

### Official description

Unspecified vulnerability in Zope 2.12.x and 2.13.x, as used in Plone 4.0.x through 4.0.9, 4.1, and 4.2 through 4.2a2, allows remote attackers to execute arbitrary commands via vectors related to the p_ class in OFS/misc_.py and the use of Python modules.

## Which versions are affected by CVE-2011-3587?

5 open source packages ship an affected version, including zope2. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zope2` | PyPI | From 2.12.0 | 2.12.20, 2.13.10 |
| `zope2` | PyPI | From 2.12.0 | 2.12.20 |
| `zope2` | PyPI | From 2.12.0 | 2.12.20 |
| `zope2` | PyPI | From 2.13.0 | 2.13.10 |
| `zope2` | PyPI | From 2.13.0 | 2.13.10 |

Products: Plone Plone, Zope Zope.

## How do I fix CVE-2011-3587?

Upgrade zope2 to a fixed version for your release line: 2.12.20 or 2.13.10.

## Is CVE-2011-3587 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-3587 exists.

Public exploit code:

- Plone and Zope XMLTools Remote Command Execution (metasploit)
- Plone and Zope - Remote Command Execution (exploitdb)

## Other vulnerabilities in Plone Plone

- [CVE-2021-33509](https://insights.sbomify.com/CVE-2021-33509/): Incorrect Permission Assignment for Critical Resource in Plone (critical 9.9)
- [CVE-2020-35190](https://insights.sbomify.com/CVE-2020-35190/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-7941](https://insights.sbomify.com/CVE-2020-7941/): Plone Unauthenticated Write Vulnerability (critical 9.8)
- [CVE-2021-33926](https://insights.sbomify.com/CVE-2021-33926/): Server-Side Request Forgery in Plone CMS (high 8.8)
- [CVE-2020-28734](https://insights.sbomify.com/CVE-2020-28734/): Improper Restriction of XML External Entity Reference in Plone (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-3587 and fix it if it is affected.

What it is: CVE-2011-3587 is a critical code injection vulnerability in Plone Plone, published on 10 Oct 2011. It can be exploited over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-3587 exists.

Affected packages and fixed versions:
- zope2 (PyPI): affected from 2.12.0; fixed in 2.12.20, 2.13.10
- zope2 (PyPI): affected from 2.12.0; fixed in 2.12.20
- zope2 (PyPI): affected from 2.12.0; fixed in 2.12.20
- zope2 (PyPI): affected from 2.13.0; fixed in 2.13.10
- zope2 (PyPI): affected from 2.13.0; fixed in 2.13.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-3587/ (Markdown: https://insights.sbomify.com/CVE-2011-3587/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-3587
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-3587
- OSV: https://osv.dev/vulnerability/CVE-2011-3587

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-3587/
Summaries are generated and may contain mistakes; the official description above is the record.
