{"answers":{"affected":"2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2011-3592 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to 3.4.5 or later.","what":"CVE-2011-3592 is a low-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 26 Dec 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2011-3592 and fix it if it is affected.\n\nWhat it is: CVE-2011-3592 is a low-severity cross-site scripting vulnerability in Phpmyadmin Phpmyadmin, published on 26 Dec 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2011-3592 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 3.4.0; fixed in 3.4.5\n- phpmyadmin/phpmyadmin (Packagist): affected from 3.4.0; fixed in 3.4.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-3592/ (Markdown: https://insights.sbomify.com/CVE-2011-3592/index.md)","id":"CVE-2011-3592","markdown":"https://insights.sbomify.com/CVE-2011-3592/index.md","name":"CVE-2011-3592","record":{"aliases":["DEBIAN-CVE-2011-3592","GHSA-5p69-rmx8-7gw7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Database management tool","requires_auth":"low_privilege","summary":"Authenticated users can inject arbitrary scripts via database, table, or column names during inline editing in phpMyAdmin.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":3.5,"severity":"low","source":"nvd","vector":"AV:N/AC:M/Au:S/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Multiple cross-site scripting (XSS) vulnerabilities in the PMA_unInlineEditRow function in js/sql.js in phpMyAdmin 3.4.x before 3.4.5 allow remote authenticated users to inject arbitrary web script or HTML via a (1) database name, (2) table name, or (3) column name that is not properly handled after an inline-editing operation.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyAdmin Multiple XSS Vulnerabilities","id":"CVE-2011-3592","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyadmin:phpmyadmin","products":["phpmyadmin:phpmyadmin"],"type":"xss","year":"2011"},"n_packages":2,"n_references":4,"next":{"headline":"Denial of service in n/a","id":"CVE-2011-3593"},"packages":[{"ecosystem":"Packagist","fixed":["3.4.5"],"introduced":["3.4.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-5p69-rmx8-7gw7"},{"ecosystem":"Packagist","fixed":["3.4.5"],"introduced":["3.4.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-5p69-rmx8-7gw7"}],"prev":{"headline":"phpMyAdmin Multiple XSS Vulnerabilities After Inline Editing and Save","id":"CVE-2011-3591"},"products":["n/a"],"published":"2014-12-26","related":[{"cvss_score":10,"headline":"Misconfiguration in n/a","id":"CVE-2008-7251","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"phpMyAdmin unsafely handles temporary files","id":"CVE-2008-7252","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2007-0203","kev_date_added":null,"published":"2007-01-11"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2004-1147","kev_date_added":null,"published":"2004-12-15"},{"cvss_score":9.8,"headline":"phpmyadmin contains SQL Injection vulnerability","id":"CVE-2020-22452","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-11768","kev_date_added":null,"published":"2019-06-05"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-6798","kev_date_added":null,"published":"2019-01-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated users can inject arbitrary scripts via database, table, or column names during inline editing in phpMyAdmin.","url":"https://insights.sbomify.com/CVE-2011-3592/"}