{"answers":{"affected":"2 open source packages ship an affected version, including cakephp/cakephp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2011-3712 in the wild and no public exploit code.","fix":"Upgrade cakephp/cakephp to 1.3.8 or later.","what":"CVE-2011-3712 is a medium-severity vulnerability in n/a, published on 23 Sep 2011. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2011-3712 and fix it if it is affected.\n\nWhat it is: CVE-2011-3712 is a medium-severity vulnerability in n/a, published on 23 Sep 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2011-3712 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cakephp/cakephp (Packagist): affected from 1.3.7; fixed in 1.3.8\n- cakephp/cakephp (Packagist): affected from 1.3.7; fixed in 1.3.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-3712/ (Markdown: https://insights.sbomify.com/CVE-2011-3712/index.md)","id":"CVE-2011-3712","markdown":"https://insights.sbomify.com/CVE-2011-3712/index.md","name":"CVE-2011-3712","record":{"aliases":["GHSA-r7p6-fr3x-r877"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"CakePHP framework","requires_auth":"none","summary":"Remote attackers can obtain sensitive installation path information via direct requests to PHP files, exposing internal server details.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"cakephp","vendor":"cakephp"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"CakePHP 1.3.7 allows remote attackers to obtain sensitive information via a direct request to a .php file, which reveals the installation path in an error message, as demonstrated by dispatcher.php and certain other files.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CakePHP 1.3.7 allows remote attackers to obtain sensitive information via a direct request to a .php file","id":"CVE-2011-3712","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"information_disclosure","year":"2011"},"n_packages":2,"n_references":3,"next":{"headline":"Information disclosure in n/a","id":"CVE-2011-3713"},"packages":[{"ecosystem":"Packagist","fixed":["1.3.8"],"introduced":["1.3.7"],"last_affected":[],"package":"cakephp/cakephp","purl":null,"source":"GHSA-r7p6-fr3x-r877"},{"ecosystem":"Packagist","fixed":["1.3.8"],"introduced":["1.3.7"],"last_affected":[],"package":"cakephp/cakephp","purl":"pkg:composer/cakephp/cakephp","source":"GHSA-r7p6-fr3x-r877"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2011-3711"},"products":["n/a"],"published":"2011-09-23","related":[{"cvss_score":9.8,"headline":"Database Query::offset() and limit() vulnerable to SQL injection in cakephp","id":"CVE-2023-22727","kev_date_added":null,"published":"2023-01-17"},{"cvss_score":8.8,"headline":"CakePHP allows method override parameters to bypass CSRF checks","id":"CVE-2020-35239","kev_date_added":null,"published":"2021-01-20"},{"cvss_score":8.8,"headline":"CakePHP might allow remote attackers to bypass CSRF protection mechanism via the _method parameter","id":"CVE-2015-8379","kev_date_added":null,"published":"2016-01-26"},{"cvss_score":7.5,"headline":"Unsafe deserialization in SmtpTransport in CakePHP","id":"CVE-2019-11458","kev_date_added":null,"published":"2019-05-08"},{"cvss_score":7.5,"headline":"CakePHP allows remote attackers to spoof their IP","id":"CVE-2016-4793","kev_date_added":null,"published":"2017-01-23"},{"cvss_score":5.4,"headline":"CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting","id":"CVE-2026-23643","kev_date_added":null,"published":"2026-01-16"},{"cvss_score":5.1,"headline":"CakePHP: Open redirect weakness via backslash bypass","id":"CVE-2026-55590","kev_date_added":null,"published":"2026-07-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Remote attackers can obtain sensitive installation path information via direct requests to PHP files, exposing internal server details.","url":"https://insights.sbomify.com/CVE-2011-3712/"}