CVE-2011-3869 Puppet arbitrary file overwrite
Local attackers can overwrite arbitrary files via symlink attacks on .k5login, potentially compromising system integrity.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2011-3869?
CVE-2011-3869 is a medium-severity path traversal vulnerability in n/a, published on 27 Oct 2011. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x allows local users to overwrite arbitrary files via a symlink attack on the .k5login file.
Weakness: CWE-59
Which versions are affected by CVE-2011-3869?
4 open source packages ship an affected version, including puppet. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
puppet RubyGems | All versions | 2.6.11 |
puppet RubyGems | All versions | 2.6.11 |
puppet RubyGems | From 2.7.0 | 2.7.5 |
puppet RubyGems | From 2.7.0 | 2.7.5 |
Products include Puppet Puppet, Puppetlabs Puppet.
How do I fix CVE-2011-3869?
Upgrade puppet to a fixed version for your release line: 2.6.11 or 2.7.5.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2011-3869 being exploited?
There is no known exploitation of CVE-2011-3869 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as DEBIAN-CVE-2011-3869, GHSA-8c56-v25w-f89c.