{"answers":{"affected":"4 open source packages ship an affected version, including puppet. It affects 2 products.","exploited":"There is no known exploitation of CVE-2011-3869 in the wild and no public exploit code.","fix":"Upgrade puppet to a fixed version for your release line: 2.6.11 or 2.7.5.","what":"CVE-2011-3869 is a medium-severity path traversal vulnerability in n/a, published on 27 Oct 2011. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2011-3869 and fix it if it is affected.\n\nWhat it is: CVE-2011-3869 is a medium-severity path traversal vulnerability in n/a, published on 27 Oct 2011. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2011-3869 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- puppet (RubyGems): affected all versions; fixed in 2.6.11\n- puppet (RubyGems): affected all versions; fixed in 2.6.11\n- puppet (RubyGems): affected from 2.7.0; fixed in 2.7.5\n- puppet (RubyGems): affected from 2.7.0; fixed in 2.7.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-3869/ (Markdown: https://insights.sbomify.com/CVE-2011-3869/index.md)","id":"CVE-2011-3869","markdown":"https://insights.sbomify.com/CVE-2011-3869/index.md","name":"CVE-2011-3869","record":{"aliases":["DEBIAN-CVE-2011-3869","GHSA-8c56-v25w-f89c"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Puppet configuration management","requires_auth":"low_privilege","summary":"Local attackers can overwrite arbitrary files via symlink attacks on .k5login, potentially compromising system integrity.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"puppet","vendor":"puppet"},{"product":"puppet","vendor":"puppetlabs"}],"cvss":{"score":6.3,"severity":"medium","source":"nvd","vector":"AV:L/AC:M/Au:N/C:N/I:C/A:C","version":"2.0"},"cwes":[{"id":"CWE-59","name":"Improper Link Resolution Before File Access"}],"description":"Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x allows local users to overwrite arbitrary files via a symlink attack on the .k5login file.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Puppet arbitrary file overwrite","id":"CVE-2011-3869","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"path_traversal","year":"2011"},"n_packages":4,"n_references":9,"next":{"headline":"Puppet allows local users to modify the permissions of arbitrary files","id":"CVE-2011-3870"},"packages":[{"ecosystem":"RubyGems","fixed":["2.6.11"],"introduced":["0"],"last_affected":[],"package":"puppet","purl":null,"source":"GHSA-8c56-v25w-f89c"},{"ecosystem":"RubyGems","fixed":["2.6.11"],"introduced":["0"],"last_affected":[],"package":"puppet","purl":"pkg:gem/puppet","source":"GHSA-8c56-v25w-f89c"},{"ecosystem":"RubyGems","fixed":["2.7.5"],"introduced":["2.7.0"],"last_affected":[],"package":"puppet","purl":null,"source":"GHSA-8c56-v25w-f89c"},{"ecosystem":"RubyGems","fixed":["2.7.5"],"introduced":["2.7.0"],"last_affected":[],"package":"puppet","purl":"pkg:gem/puppet","source":"GHSA-8c56-v25w-f89c"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2011-3868"},"products":["n/a"],"published":"2011-10-27","related":[{"cvss_score":9.8,"headline":"Puppet Improper Access Control","id":"CVE-2016-2785","kev_date_added":null,"published":"2016-06-10"},{"cvss_score":8.8,"headline":"SQL injection in Puppet DB","id":"CVE-2021-27021","kev_date_added":null,"published":"2021-07-20"},{"cvss_score":8.8,"headline":"Privilege escalation in Puppet Enterprise and Puppet Agent","id":"CVE-2018-6513","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.8,"headline":"Privilege escalation in Puppet Agent","id":"CVE-2018-6514","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.8,"headline":"Code injection in Puppet Agent","id":"CVE-2018-6515","kev_date_added":null,"published":"2018-06-11"},{"cvss_score":7.5,"headline":"Puppet Improper Input Validation vulnerability","id":"CVE-2013-1655","kev_date_added":null,"published":"2013-03-20"},{"cvss_score":6.9,"headline":"Puppet Privilege Escallation","id":"CVE-2012-1053","kev_date_added":null,"published":"2012-05-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can overwrite arbitrary files via symlink attacks on .k5login, potentially compromising system integrity.","url":"https://insights.sbomify.com/CVE-2011-3869/"}