# CVE-2011-3923: Struts ParameterInterceptor vulnerability allows remote command execution

> Remote attackers can bypass security protections in Apache Struts to execute arbitrary commands on the server.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Nov 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-j68f-8h6p-9h5q

## What is CVE-2011-3923?

CVE-2011-3923 is a critical command injection vulnerability in Apache Struts, published on 1 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Struts before 2.3.1.2 allows remote attackers to bypass security protections in the ParameterInterceptor class and execute arbitrary commands.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2011-3923?

2 open source packages ship an affected version, including org.apache.struts:struts2-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.3.1.2 |
| `org.apache.struts:struts2-core` | Maven | From 2.0.0 | 2.3.1.2 |

Products: Apache Struts, Redhat Jboss Enterprise Web Server.

## How do I fix CVE-2011-3923?

Upgrade org.apache.struts:struts2-core to 2.3.1.2 or later.

## Is CVE-2011-3923 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-3923 exists.

Public exploit code:

- Apache Struts ParametersInterceptor Remote Code Execution (metasploit)
- Apache Struts - 'ParametersInterceptor' Remote Code Execution (Metasploit) (exploitdb)

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-3923 and fix it if it is affected.

What it is: CVE-2011-3923 is a critical command injection vulnerability in Apache Struts, published on 1 Nov 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-3923 exists.

Affected packages and fixed versions:
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.1.2
- org.apache.struts:struts2-core (Maven): affected from 2.0.0; fixed in 2.3.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-3923/ (Markdown: https://insights.sbomify.com/CVE-2011-3923/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-3923
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-3923
- OSV: https://osv.dev/vulnerability/CVE-2011-3923

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-3923/
Summaries are generated and may contain mistakes; the official description above is the record.
