# CVE-2011-4030: Plone anonymous access to sub-objects in CMFEditions where KwAsAttributes classes were publishable

> Remote attackers can access restricted sub-objects in Plone's CMFEditions component due to missing authorization checks on publishable classes.

- **Severity:** Critical 9.3 (`AV:N/AC:M/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2011
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-pwgm-jvqv-6v8p, PYSEC-2026-897

## What is CVE-2011-4030?

CVE-2011-4030 is a critical missing authorization vulnerability in Plone Plone, published on 10 Oct 2011. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The CMFEditions component 2.x in Plone 4.0.x through 4.0.9, 4.1, and 4.2 through 4.2a2 does not prevent the KwAsAttributes classes from being publishable, which allows remote attackers to access sub-objects via unspecified vectors, a different vulnerability than CVE-2011-3587.

Weakness: CWE-264

## Which versions are affected by CVE-2011-4030?

7 open source packages ship an affected version, including plone and Plone. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone` | PyPI | From 4.0 | 4.0.10, 4.1.1, 4.2a3 |
| `plone` | PyPI | From 4.0 | 4.0.10 |
| `plone` | PyPI | From 4.1 | 4.1.1 |
| `plone` | PyPI | From 4.2a1 | 4.2a3 |
| `Plone` | PyPI | From 4.0 | 4.0.10 |
| `Plone` | PyPI | From 4.1 | 4.1.1 |
| `Plone` | PyPI | From 4.2a1 | 4.2a3 |

Products: Plone Cmfeditions, Plone Plone.

## How do I fix CVE-2011-4030?

Upgrade plone to a fixed version for your release line: 4.0.10, 4.1.1 or 4.2a3.

## Is CVE-2011-4030 being exploited?

There is no known exploitation of CVE-2011-4030 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-4030 and fix it if it is affected.

What it is: CVE-2011-4030 is a critical missing authorization vulnerability in Plone Plone, published on 10 Oct 2011. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-4030 in the wild and no public exploit code.

Affected packages and fixed versions:
- plone (PyPI): affected from 4.0; fixed in 4.0.10, 4.1.1, 4.2a3
- plone (PyPI): affected from 4.0; fixed in 4.0.10
- plone (PyPI): affected from 4.1; fixed in 4.1.1
- plone (PyPI): affected from 4.2a1; fixed in 4.2a3
- Plone (PyPI): affected from 4.0; fixed in 4.0.10
- Plone (PyPI): affected from 4.1; fixed in 4.1.1
- Plone (PyPI): affected from 4.2a1; fixed in 4.2a3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-4030/ (Markdown: https://insights.sbomify.com/CVE-2011-4030/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-4030
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-4030
- OSV: https://osv.dev/vulnerability/CVE-2011-4030

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-4030/
Summaries are generated and may contain mistakes; the official description above is the record.
