# CVE-2011-4103: Django-piston and Django-tastypie do not properly deserialize YAML data

> Remote attackers can execute arbitrary Python code via unsafe YAML deserialization in the Django Piston library.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Oct 2014
- **Updated:** 7 Aug 2024
- **Also known as:** DSA-2344-1, GHSA-pvhp-v9qp-xf5r, PYSEC-2014-24

## What is CVE-2011-4103?

CVE-2011-4103 is a high-severity unsafe deserialization vulnerability in n/a, published on 27 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

emitters.py in Django Piston before 0.2.3 and 0.2.x before 0.2.2.1 does not properly deserialize YAML data, which allows remote attackers to execute arbitrary Python code via vectors related to the yaml.load method.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2011-4103?

3 open source packages ship an affected version, including django-piston. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django-piston` | PyPI | All versions | 0.2.3 |
| `django-piston` | PyPI | From 0.2.0 | 0.2.2.1 |
| `django-piston` | PyPI | From 0.2.0 | 0.2.2.1 |

Products: Djangoproject Piston.

## How do I fix CVE-2011-4103?

Upgrade django-piston to a fixed version for your release line: 0.2.3 or 0.2.2.1.

## Is CVE-2011-4103 being exploited?

There is no known exploitation of CVE-2011-4103 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-4103 and fix it if it is affected.

What it is: CVE-2011-4103 is a high-severity unsafe deserialization vulnerability in n/a, published on 27 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-4103 in the wild and no public exploit code.

Affected packages and fixed versions:
- django-piston (PyPI): affected all versions; fixed in 0.2.3
- django-piston (PyPI): affected from 0.2.0; fixed in 0.2.2.1
- django-piston (PyPI): affected from 0.2.0; fixed in 0.2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-4103/ (Markdown: https://insights.sbomify.com/CVE-2011-4103/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-4103
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-4103
- OSV: https://osv.dev/vulnerability/CVE-2011-4103

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-4103/
Summaries are generated and may contain mistakes; the official description above is the record.
