{"answers":{"affected":"3 open source packages ship an affected version, including django-tastypie. It affects 1 product.","exploited":"There is no known exploitation of CVE-2011-4104 in the wild and no public exploit code.","fix":"Upgrade django-tastypie to 0.9.10 or later.","what":"CVE-2011-4104 is a high-severity unsafe deserialization vulnerability in n/a, published on 27 Oct 2014. It can be exploited over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2011-4104 and fix it if it is affected.\n\nWhat it is: CVE-2011-4104 is a high-severity unsafe deserialization vulnerability in n/a, published on 27 Oct 2014. It can be exploited over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2011-4104 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- django-tastypie (PyPI): affected all versions; fixed in 0.9.10\n- django-tastypie (PyPI): affected all versions; fixed in 0.9.10\n- django-tastypie (PyPI): affected all versions; fixed in 0.9.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-4104/ (Markdown: https://insights.sbomify.com/CVE-2011-4104/index.md)","id":"CVE-2011-4104","markdown":"https://insights.sbomify.com/CVE-2011-4104/index.md","name":"CVE-2011-4104","record":{"aliases":["DEBIAN-CVE-2011-4104","GHSA-qgvw-qc2q-gv5q","PYSEC-2014-25"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Django Tastypie library","requires_auth":"unknown","summary":"Remote attackers can execute arbitrary Python code via unsafe YAML deserialization in the Django Tastypie library.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"tastypie","vendor":"djangoproject"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The from_yaml method in serializers.py in Django Tastypie before 0.9.10 does not properly deserialize YAML data, which allows remote attackers to execute arbitrary Python code via vectors related to the yaml.load method.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Django Tastypie Improper Deserialization of YAML Data","id":"CVE-2011-4104","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2011"},"n_packages":3,"n_references":5,"next":{"headline":"Path traversal in n/a","id":"CVE-2011-4105"},"packages":[{"ecosystem":"PyPI","fixed":["0.9.10"],"introduced":["0"],"last_affected":[],"package":"django-tastypie","purl":null,"source":"GHSA-qgvw-qc2q-gv5q"},{"ecosystem":"PyPI","fixed":["0.9.10"],"introduced":["0"],"last_affected":[],"package":"django-tastypie","purl":"pkg:pypi/django-tastypie","source":"GHSA-qgvw-qc2q-gv5q"},{"ecosystem":"PyPI","fixed":["0.9.10"],"introduced":["0"],"last_affected":[],"package":"django-tastypie","purl":"pkg:pypi/django-tastypie","source":"PYSEC-2014-25"}],"prev":{"headline":"Django-piston and Django-tastypie do not properly deserialize YAML data","id":"CVE-2011-4103"},"products":["n/a"],"published":"2014-10-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary Python code via unsafe YAML deserialization in the Django Tastypie library.","url":"https://insights.sbomify.com/CVE-2011-4104/"}