CVE-2011-4107 phpMyAdmin vulnerable to XML external entity (XXE) injection attack
Authenticated attackers can read arbitrary files via XML external entity injection in the XML import plugin.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2011-4107?
CVE-2011-4107 is a medium-severity vulnerability in Debian Debian Linux, published on 17 Nov 2011. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The simplexml_load_string function in the XML import plug-in (libraries/import/xml.php) in phpMyAdmin 3.4.x before 3.4.7.1 and 3.3.x before 3.3.10.5 allows remote authenticated users to read arbitrary files via XML data containing external entity references, aka an XML external entity (XXE) injection attack.
Weakness: CWE-611
Which versions are affected by CVE-2011-4107?
4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 3.3.0 | 3.3.10.5 |
phpmyadmin/phpmyadmin Packagist | From 3.3.0 | 3.3.10.5 |
phpmyadmin/phpmyadmin Packagist | From 3.4.0 | 3.4.7.1 |
phpmyadmin/phpmyadmin Packagist | From 3.4.0 | 3.4.7.1 |
Products include Debian Debian Linux, Fedoraproject Fedora, Phpmyadmin Phpmyadmin.
How do I fix CVE-2011-4107?
Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 3.3.10.5 or 3.4.7.1.
Is CVE-2011-4107 being exploited?
There is no known exploitation of CVE-2011-4107 in the wild and no public exploit code.
Public exploit code: 1 Exploit-DB entry and 1 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2011-4107, GHSA-q4mm-89q2-xffg.