{"answers":{"affected":"4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 3 products.","exploited":"There is no known exploitation of CVE-2011-4107 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 3.3.10.5 or 3.4.7.1.","what":"CVE-2011-4107 is a medium-severity vulnerability in Debian Debian Linux, published on 17 Nov 2011. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2011-4107 and fix it if it is affected.\n\nWhat it is: CVE-2011-4107 is a medium-severity vulnerability in Debian Debian Linux, published on 17 Nov 2011. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2011-4107 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 3.3.0; fixed in 3.3.10.5\n- phpmyadmin/phpmyadmin (Packagist): affected from 3.3.0; fixed in 3.3.10.5\n- phpmyadmin/phpmyadmin (Packagist): affected from 3.4.0; fixed in 3.4.7.1\n- phpmyadmin/phpmyadmin (Packagist): affected from 3.4.0; fixed in 3.4.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-4107/ (Markdown: https://insights.sbomify.com/CVE-2011-4107/index.md)","id":"CVE-2011-4107","markdown":"https://insights.sbomify.com/CVE-2011-4107/index.md","name":"CVE-2011-4107","record":{"aliases":["DEBIAN-CVE-2011-4107","GHSA-q4mm-89q2-xffg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyAdmin","requires_auth":"low_privilege","summary":"Authenticated attackers can read arbitrary files via XML external entity injection in the XML import plugin.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"The simplexml_load_string function in the XML import plug-in (libraries/import/xml.php) in phpMyAdmin 3.4.x before 3.4.7.1 and 3.3.x before 3.3.10.5 allows remote authenticated users to read arbitrary files via XML data containing external entity references, aka an XML external entity (XXE) injection attack.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2012-01-14","github_poc":1,"max_poc_stars":4,"metasploit":0,"nuclei":0,"refs":[{"date":"2017-04-19T14:54:13Z","kind":"github_poc","ref":"https://github.com/SECFORCE/CVE-2011-4107","stars":4,"title":"phpMyAdmin 3.3.X and 3.4.X - Local File Inclusion"},{"date":"2012-01-14","kind":"exploitdb","ref":"18371","stars":null,"title":"phpMyAdmin 3.3.x/3.4.x - Local File Inclusion via XML External Entity Injection (Metasploit)"}],"tier":"poc_unverified"},"has_fix":true,"headline":"phpMyAdmin vulnerable to XML external entity (XXE) injection attack","id":"CVE-2011-4107","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora","phpmyadmin:phpmyadmin"],"type":"xxe","year":"2011"},"n_packages":4,"n_references":17,"next":{"headline":"Weak cryptography in n/a","id":"CVE-2011-4108"},"packages":[{"ecosystem":"Packagist","fixed":["3.3.10.5"],"introduced":["3.3.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-q4mm-89q2-xffg"},{"ecosystem":"Packagist","fixed":["3.3.10.5"],"introduced":["3.3.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-q4mm-89q2-xffg"},{"ecosystem":"Packagist","fixed":["3.4.7.1"],"introduced":["3.4.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-q4mm-89q2-xffg"},{"ecosystem":"Packagist","fixed":["3.4.7.1"],"introduced":["3.4.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-q4mm-89q2-xffg"}],"prev":{"headline":"File upload in n/a","id":"CVE-2011-4106"},"products":["n/a"],"published":"2011-11-17","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Authenticated attackers can read arbitrary files via XML external entity injection in the XML import plugin.","url":"https://insights.sbomify.com/CVE-2011-4107/"}