# CVE-2011-4107: phpMyAdmin vulnerable to XML external entity (XXE) injection attack

> Authenticated attackers can read arbitrary files via XML external entity injection in the XML import plugin.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Nov 2011
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2011-4107, GHSA-q4mm-89q2-xffg

## What is CVE-2011-4107?

CVE-2011-4107 is a medium-severity vulnerability in Debian Debian Linux, published on 17 Nov 2011. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The simplexml_load_string function in the XML import plug-in (libraries/import/xml.php) in phpMyAdmin 3.4.x before 3.4.7.1 and 3.3.x before 3.3.10.5 allows remote authenticated users to read arbitrary files via XML data containing external entity references, aka an XML external entity (XXE) injection attack.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2011-4107?

4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 3.3.0 | 3.3.10.5 |
| `phpmyadmin/phpmyadmin` | Packagist | From 3.3.0 | 3.3.10.5 |
| `phpmyadmin/phpmyadmin` | Packagist | From 3.4.0 | 3.4.7.1 |
| `phpmyadmin/phpmyadmin` | Packagist | From 3.4.0 | 3.4.7.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Phpmyadmin Phpmyadmin.

## How do I fix CVE-2011-4107?

Upgrade phpmyadmin/phpmyadmin to a fixed version for your release line: 3.3.10.5 or 3.4.7.1.

## Is CVE-2011-4107 being exploited?

There is no known exploitation of CVE-2011-4107 in the wild and no public exploit code.

Public exploit code:

- phpMyAdmin 3.3.X and 3.4.X - Local File Inclusion (github_poc): https://github.com/SECFORCE/CVE-2011-4107
- phpMyAdmin 3.3.x/3.4.x - Local File Inclusion via XML External Entity Injection (Metasploit) (exploitdb)

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-4107 and fix it if it is affected.

What it is: CVE-2011-4107 is a medium-severity vulnerability in Debian Debian Linux, published on 17 Nov 2011. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-4107 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 3.3.0; fixed in 3.3.10.5
- phpmyadmin/phpmyadmin (Packagist): affected from 3.3.0; fixed in 3.3.10.5
- phpmyadmin/phpmyadmin (Packagist): affected from 3.4.0; fixed in 3.4.7.1
- phpmyadmin/phpmyadmin (Packagist): affected from 3.4.0; fixed in 3.4.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-4107/ (Markdown: https://insights.sbomify.com/CVE-2011-4107/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-4107
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-4107
- OSV: https://osv.dev/vulnerability/CVE-2011-4107

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-4107/
Summaries are generated and may contain mistakes; the official description above is the record.
