# CVE-2011-4137: Denial of service in django

> Remote attackers can cause denial of service in Django applications by submitting URLs that trigger resource exhaustion during validation.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2011
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2011-4137, GHSA-3jqw-crqj-w8qw, PYSEC-2011-2

## What is CVE-2011-4137?

CVE-2011-4137 is a medium-severity denial of service vulnerability in Djangoproject Django, published on 19 Oct 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The verify_exists functionality in the URLField implementation in Django before 1.2.7 and 1.3.x before 1.3.1 relies on Python libraries that attempt access to an arbitrary URL with no timeout, which allows remote attackers to cause a denial of service (resource consumption) via a URL associated with (1) a slow response, (2) a completed TCP connection with no application data sent, or (3) a large amount of application data, a related issue to CVE-2011-1521.

Weakness: CWE-399

## Which versions are affected by CVE-2011-4137?

5 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | All versions | 1.2.7, 1.3.1 |
| `django` | PyPI | All versions | 1.2.7 |
| `django` | PyPI | From 1.3 | 1.3.1 |
| `Django` | PyPI | All versions | 1.2.7 |
| `Django` | PyPI | From 1.3 | 1.3.1 |

Products: Djangoproject Django.

## How do I fix CVE-2011-4137?

Upgrade django to a fixed version for your release line: 1.2.7 or 1.3.1.

## Is CVE-2011-4137 being exploited?

There is no known exploitation of CVE-2011-4137 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2011-4137 and fix it if it is affected.

What it is: CVE-2011-4137 is a medium-severity denial of service vulnerability in Djangoproject Django, published on 19 Oct 2011. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2011-4137 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected all versions; fixed in 1.2.7, 1.3.1
- django (PyPI): affected all versions; fixed in 1.2.7
- django (PyPI): affected from 1.3; fixed in 1.3.1
- Django (PyPI): affected all versions; fixed in 1.2.7
- Django (PyPI): affected from 1.3; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2011-4137/ (Markdown: https://insights.sbomify.com/CVE-2011-4137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2011-4137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2011-4137
- OSV: https://osv.dev/vulnerability/CVE-2011-4137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2011-4137/
Summaries are generated and may contain mistakes; the official description above is the record.
