CVE-2011-4278 Moodle XSS In Tag Autocomplete functionality

Medium 4.3 Published Updated

Remote attackers can inject arbitrary web script or HTML via the tag autocomplete functionality in Moodle, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2011-4278?

CVE-2011-4278 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 16 Jul 2012. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in the tag autocomplete functionality in Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Weakness: CWE-79

Which versions are affected by CVE-2011-4278?

4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions1.9.11
moodle/moodle PackagistAll versions1.9.11
moodle/moodle PackagistFrom 2.02.0.2
moodle/moodle PackagistFrom 2.02.0.2

Products include Moodle Moodle.

How do I fix CVE-2011-4278?

Upgrade moodle/moodle to a fixed version for your release line: 1.9.11 or 2.0.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2011-4278 being exploited?

There is no known exploitation of CVE-2011-4278 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-6656-6qwx-4c2m.

Is CVE-2011-4278 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free