{"answers":{"affected":"2 open source packages ship an affected version, including moodle/moodle. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-4280 exists.","fix":"Upgrade moodle/moodle to 2.0.2 or later.","what":"CVE-2011-4280 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 16 Jul 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2011-4280 and fix it if it is affected.\n\nWhat it is: CVE-2011-4280 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 16 Jul 2012. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2011-4280 exists.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 2.0; fixed in 2.0.2\n- moodle/moodle (Packagist): affected from 2.0; fixed in 2.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2011-4280/ (Markdown: https://insights.sbomify.com/CVE-2011-4280/index.md)","id":"CVE-2011-4280","markdown":"https://insights.sbomify.com/CVE-2011-4280/index.md","name":"CVE-2011-4280","record":{"aliases":["GHSA-mx5g-3vxh-rgm8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP code coverage library","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via the Spike PHPCoverage library, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"},{"product":"spike_phpcoverage","vendor":"nimish_pachapurkar"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the Spike PHPCoverage (aka spikephpcoverage) library, as used in Moodle 2.0.x before 2.0.2 and other products, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2011-02-01","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2011-02-01","kind":"exploitdb","ref":"35297","stars":null,"title":"Moodle 2.0.1 - 'PHPCOVERAGE_HOME' Cross-Site Scripting"}],"tier":"weaponised"},"has_fix":true,"headline":"Moodle vulnerable to XSS via bundled spikephpcoverage library","id":"CVE-2011-4280","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"xss","year":"2011"},"n_packages":2,"n_references":3,"next":{"headline":"Moodle vulnerable to Cross-Site Request Forgery","id":"CVE-2011-4281"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.2"],"introduced":["2.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-mx5g-3vxh-rgm8"},{"ecosystem":"Packagist","fixed":["2.0.2"],"introduced":["2.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-mx5g-3vxh-rgm8"}],"prev":{"headline":"Moodle does not use the forceloginforprofiles setting for course-profiles access control","id":"CVE-2011-4279"},"products":["n/a"],"published":"2012-07-16","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via the Spike PHPCoverage library, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2011-4280/"}