CVE-2011-4283 Moodle allows remote attackers to obtain sensitive information
Remote attackers can access sensitive IMS enterprise enrolment data by requesting a specific XML file in the course-files area.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2011-4283?
CVE-2011-4283 is a medium-severity vulnerability in Moodle Moodle, published on 16 Jul 2012. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 places an IMS enterprise enrolment file in the course-files area, which allows remote attackers to obtain sensitive information via a request for imsenterprise-enrol.xml.
Weakness: CWE-200
Which versions are affected by CVE-2011-4283?
4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 1.9.0 | 1.9.11 |
moodle/moodle Packagist | From 1.9.0 | 1.9.11 |
moodle/moodle Packagist | From 2.0.0 | 2.0.2 |
moodle/moodle Packagist | From 2.0.0 | 2.0.2 |
Products include Moodle Moodle.
How do I fix CVE-2011-4283?
Upgrade moodle/moodle to a fixed version for your release line: 1.9.11 or 2.0.2.
Is CVE-2011-4283 being exploited?
There is no known exploitation of CVE-2011-4283 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-m3xp-4hf3-qfpp.