CVE-2011-4286 Moodle vulnerable to Cross-site Scripting
Remote attackers can inject arbitrary web script or HTML via malicious Flash Video or YouTube files in Moodle's media filter, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2011-4286?
CVE-2011-4286 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 16 Jul 2012. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in the media-filter implementation in filter/mediaplugin/filter.php in Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 allow remote attackers to inject arbitrary web script or HTML via vectors involving (1) Flash Video (aka FLV) files and (2) YouTube videos.
Weakness: CWE-79
Which versions are affected by CVE-2011-4286?
4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 1.9.0 | 1.9.11 |
moodle/moodle Packagist | From 1.9.0 | 1.9.11 |
moodle/moodle Packagist | From 2.0.0 | 2.0.2 |
moodle/moodle Packagist | From 2.0.0 | 2.0.2 |
Products include Moodle Moodle.
How do I fix CVE-2011-4286?
Upgrade moodle/moodle to a fixed version for your release line: 1.9.11 or 2.0.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2011-4286 being exploited?
There is no known exploitation of CVE-2011-4286 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-86v9-gqh9-8268.