CVE-2011-4297 Moodle does not properly restrict comment capabilities
Remote attackers with guest access can post comments on front-page activities due to improper capability restrictions in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2011-4297?
CVE-2011-4297 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 16 Jul 2012. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
comment/lib.php in Moodle 2.0.x before 2.0.4 and 2.1.x before 2.1.1 does not properly restrict comment capabilities, which allows remote attackers to post a comment by leveraging the guest role and operating on a front-page activity.
Weakness: CWE-264
Which versions are affected by CVE-2011-4297?
4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.0.0 | 2.0.4 |
moodle/moodle Packagist | From 2.0.0 | 2.0.4 |
moodle/moodle Packagist | From 2.1.0 | 2.1.1 |
moodle/moodle Packagist | From 2.1.0 | 2.1.1 |
Products include Moodle Moodle.
How do I fix CVE-2011-4297?
Upgrade moodle/moodle to a fixed version for your release line: 2.0.4 or 2.1.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2011-4297 being exploited?
There is no known exploitation of CVE-2011-4297 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-62wv-866c-rh86.