CVE-2011-4298 Moodle vulnerable to Cross-Site Request Forgery
Remote attackers can hijack user sessions to modify wiki data in Moodle via CSRF, requiring user interaction.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2011-4298?
CVE-2011-4298 is a medium-severity vulnerability in Moodle Moodle, published on 11 Jul 2012. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Multiple cross-site request forgery (CSRF) vulnerabilities in mod/wiki/ components in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allow remote attackers to hijack the authentication of arbitrary users for requests that modify wiki data.
Weakness: CWE-352
Which versions are affected by CVE-2011-4298?
4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.0.0 | 2.0.5 |
moodle/moodle Packagist | From 2.0.0 | 2.0.5 |
moodle/moodle Packagist | From 2.1.0 | 2.1.2 |
moodle/moodle Packagist | From 2.1.0 | 2.1.2 |
Products include Moodle Moodle.
How do I fix CVE-2011-4298?
Upgrade moodle/moodle to a fixed version for your release line: 2.0.5 or 2.1.2.
Is CVE-2011-4298 being exploited?
There is no known exploitation of CVE-2011-4298 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-8hxm-42v5-66hm.